summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-03-09 17:02:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-12 22:11:45 +0000
commit8b1fa2acd19ac6c0587f9eba9eae9818f07a25af (patch)
tree67f104a6d2f1f4410308fe8168a8124f43d41118 /meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
parent7bd32b9ce6436315d6e44e186aeeb4bb8708559c (diff)
downloadpoky-8b1fa2acd19ac6c0587f9eba9eae9818f07a25af.tar.gz
webkitgtk: enable gobject introspection
(From OE-Core rev: cfd1ccb615a1196f4501f8fea29060a9e0b599f5) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.10.7.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.10.7.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
index 8812967603..849a33a1e7 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
@@ -15,11 +15,14 @@ SRC_URI = "\
15 file://clang.patch \ 15 file://clang.patch \
16 file://0001-Enable-backtrace-on-linux-when-using-glibc.patch \ 16 file://0001-Enable-backtrace-on-linux-when-using-glibc.patch \
17 file://0001-Fix-build-with-non-glibc-libraries-on-linux.patch \ 17 file://0001-Fix-build-with-non-glibc-libraries-on-linux.patch \
18 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
19 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
20 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
18 " 21 "
19SRC_URI[md5sum] = "84832b9d8329413b4f1d87df5f7e8efe" 22SRC_URI[md5sum] = "84832b9d8329413b4f1d87df5f7e8efe"
20SRC_URI[sha256sum] = "990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e" 23SRC_URI[sha256sum] = "990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e"
21 24
22inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even 25inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even gobject-introspection
23 26
24# depends on libxt 27# depends on libxt
25REQUIRED_DISTRO_FEATURES = "x11" 28REQUIRED_DISTRO_FEATURES = "x11"
@@ -51,7 +54,7 @@ PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
51EXTRA_OECMAKE = " \ 54EXTRA_OECMAKE = " \
52 -DPORT=GTK \ 55 -DPORT=GTK \
53 -DCMAKE_BUILD_TYPE=Release \ 56 -DCMAKE_BUILD_TYPE=Release \
54 -DENABLE_INTROSPECTION=OFF \ 57 ${@bb.utils.contains('COMBINED_FEATURES', 'gobject-introspection-data', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
55 -DENABLE_GTKDOC=OFF \ 58 -DENABLE_GTKDOC=OFF \
56 -DENABLE_MINIBROWSER=ON \ 59 -DENABLE_MINIBROWSER=ON \
57 " 60 "
@@ -76,3 +79,10 @@ FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbu
76 79
77# http://errors.yoctoproject.org/Errors/Details/20370/ 80# http://errors.yoctoproject.org/Errors/Details/20370/
78ARM_INSTRUCTION_SET = "arm" 81ARM_INSTRUCTION_SET = "arm"
82
83# Invalid data memory access: 0x00000000
84# ...
85# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
86# Segmentation fault
87EXTRA_OECMAKE_append_powerpc = " -DENABLE_INTROSPECTION=OFF "
88