summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-11 12:24:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-12 15:00:46 +0100
commitb36f998fc7b185e67d094fe59239f7a77167a9c4 (patch)
tree874b9d8fc1547d86871792d1a42b1fcac02d4467 /meta/recipes-sato/webkit/webkit-gtk_svn.bb
parent01552639c901223843b19410cb440c2da7726997 (diff)
downloadpoky-b36f998fc7b185e67d094fe59239f7a77167a9c4.tar.gz
webkit-gtk: update SRCREV
The layout of the repository has changed, so we need to account for that: * fixed license checksums * fixed SRC_URI * fixed SRCREV_FORMAT PCRE is gone, so no need for the dftables hack anymore But most importantly, this fixes the crash issues when using javascript (e.g. github.com) Tested on: * usrp-e1xx/angstrom-2011.07 (From OE-Core rev: 7df4f5f3d64f1f60814cea60d83270be7bfa4f2c) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_svn.bb')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb53
1 files changed, 21 insertions, 32 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index af43ae896c..5eb9b2efc7 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -3,27 +3,23 @@ HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/" 3BUGTRACKER = "http://bugs.webkit.org/"
4 4
5LICENSE = "BSD & LGPLv2+" 5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \ 6LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
7 file://WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \ 7 file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
8 file://JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90" 8 file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90"
9 9
10DEPENDS = "enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3" 10DEPENDS = "enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3"
11DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native-runtime sqlite3" 11DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native-runtime sqlite3"
12 12
13SRCREV_FORMAT = "webcore-rwebkit" 13SRCREV_FORMAT = "source"
14 14
15SRCREV = "72836" 15SRCREV = "90727"
16PV = "1.3.7+svnr${SRCPV}" 16PV = "1.5.1+svnr${SRCPV}"
17PR = "r2" 17PR = "r0"
18 18
19SRC_URI = "\ 19SRC_URI = "\
20 svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \ 20 svn://svn.webkit.org/repository/webkit/trunk/;module=Source;proto=http;name=source \
21 svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptGlue;proto=http \
22 svn://svn.webkit.org/repository/webkit/trunk/;module=WebCore;proto=http;name=webcore \
23 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
24 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \ 21 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
25 svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \ 22 svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http \
26 svn://svn.webkit.org/repository/webkit/trunk/;module=autotools;proto=http \
27 file://Makefile \ 23 file://Makefile \
28 file://Makefile.shared \ 24 file://Makefile.shared \
29 file://autogen.sh \ 25 file://autogen.sh \
@@ -41,36 +37,29 @@ EXTRA_OECONF = "\
41 --enable-debug=no \ 37 --enable-debug=no \
42 --enable-svg \ 38 --enable-svg \
43 --enable-icon-database=yes \ 39 --enable-icon-database=yes \
44 --disable-fast-malloc \ 40 --enable-fullscreen-api \
41 --enable-image-resizer \
42 --enable-link-prefetch \
43 UNICODE_CFLAGS=-D_REENTRANT \
45 " 44 "
46 45
47EXTRA_AUTORECONF = " -I autotools " 46EXTRA_AUTORECONF = " -I Source/autotools "
48 47
49do_compile_prepend() { 48do_configure_append() {
50 mkdir -p ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/ 49 # somethings wrong with icu, fix it up manually
51 mkdir -p ${S}/Programs/ 50 for makefile in $(find ${S} -name "GNUmakefile") ; do
52 cd ${S}/JavaScriptCore/pcre 51 sed -i s:-I/usr/include::g $makefile
53 if test -e dftables.c 52 done
54 then
55 ${BUILD_CC} dftables.c -o dftables -I. -I../wtf
56 elif test -e dftables.cpp
57 then
58 ${BUILD_CXX} dftables.cpp -o dftables -I. -I../wtf
59 fi
60 cp dftables ${S}/WebKitBuilds/Debug/JavaScriptCore/pcre/tmp/
61 cp dftables ${S}/Programs/
62 cd ${S}
63} 53}
64 54
65do_install_prepend() { 55do_install_prepend() {
66 cp ${S}/Programs/.libs/jsc ${S}/Programs/jsc-1 || true 56 cp ${S}/Programs/.libs/jsc ${S}/Programs/jsc-1 || true
67} 57}
68 58
69
70PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore" 59PACKAGES =+ "${PN}-webinspector ${PN}launcher-dbg ${PN}launcher libjavascriptcore"
71FILES_${PN}launcher = "${bindir}/GtkLauncher" 60FILES_${PN}launcher = "${bindir}/GtkLauncher"
72FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher" 61FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
73FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*" 62FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*"
74FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/" 63FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/"
75FILES_${PN} += "${datadir}/webkit-*/resources/error.html \ 64FILES_${PN} += "${datadir}/webkit-*/resources/error.html \
76 ${datadir}/webkitgtk-*/images \ 65 ${datadir}/webkitgtk-*/images \