summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2012-06-12 05:39:43 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-21 11:59:32 +0100
commit026d502b2a8aed05120a93d4d2917b9da2c16880 (patch)
tree24db36dcddc53092b77661727672d5db8313affa /meta/recipes-sato/webkit/webkit-gtk_svn.bb
parente81f7c61529b0765b00d5e3789e601bb75e3cfe1 (diff)
downloadpoky-026d502b2a8aed05120a93d4d2917b9da2c16880.tar.gz
webkit-gtk: Apply work around for all PowerPC targets
The current patch for bug #1570 only applies to qemuppc but should be applicable for all PowerPC targets. Also update the patch so that only one language backend, either ICU or PANGO, is built. Also remove some old customizations (dependencies on darwin) as these should now be handled in a layer specific .bbappend file. (From OE-Core rev: 87eae0851e5334734df40a833596c6cbc6715f7f) Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkit-gtk_svn.bb')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index 9381486e20..716afceda2 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -7,10 +7,13 @@ LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md
7 file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \ 7 file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
8 file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90" 8 file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90"
9 9
10DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3" 10# Choice of language backends - icu has issues on Big Endian machines so use pango
11ICU_LIB = "icu"
12ICU_LIB_powerpc = "pango"
13
14DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
15 gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
11DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}" 16DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
12DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native-runtime sqlite3"
13DEPENDS_append_qemuppc += "pango"
14 17
15SRCREV_FORMAT = "source" 18SRCREV_FORMAT = "source"
16 19
@@ -48,10 +51,10 @@ EXTRA_OECONF = "\
48 UNICODE_CFLAGS=-D_REENTRANT \ 51 UNICODE_CFLAGS=-D_REENTRANT \
49 " 52 "
50 53
51#default unicode backend icu breaks in cross-compile when target and host owns different endian type 54#default unicode backend icu breaks in cross-compile when target and host are different endian type
52EXTRA_OECONF_append_qemuppc += "--with-unicode-backend=glib" 55EXTRA_OECONF_append_powerpc += "--with-unicode-backend=glib"
53 56
54CPPFLAGS_append_qemuppc += "-I${STAGING_INCDIR}/pango-1.0 \ 57CPPFLAGS_append_powerpc += "-I${STAGING_INCDIR}/pango-1.0 \
55 -I${STAGING_LIBDIR}/glib-2.0/include \ 58 -I${STAGING_LIBDIR}/glib-2.0/include \
56 -I${STAGING_INCDIR}/glib-2.0" 59 -I${STAGING_INCDIR}/glib-2.0"
57 60