summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web/web_git.bb
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2011-11-03 14:13:15 -0700
committerJoshua Lock <josh@linux.intel.com>2011-11-14 18:01:46 -0800
commitc9805a0c3c9dee5373ded793eac45ebe94df038b (patch)
tree64b05dff91b99cd401c571cccc391a618d881492 /meta/recipes-sato/web/web_git.bb
parent3545f453aa7320dcf0eedb39247735359095cb51 (diff)
downloadpoky-c9805a0c3c9dee5373ded793eac45ebe94df038b.tar.gz
web: switch to git and fix Makefile
The SVN repo is no longer available and we don't have a mirror of the SVN tarball. Further the Makefile in git uses spaces where the Make parser expects tabs. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/web/web_git.bb')
-rw-r--r--meta/recipes-sato/web/web_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web_git.bb b/meta/recipes-sato/web/web_git.bb
new file mode 100644
index 0000000000..04328422b4
--- /dev/null
+++ b/meta/recipes-sato/web/web_git.bb
@@ -0,0 +1,27 @@
1LICENSE = "GPLv2"
2SECTION = "x11"
3DEPENDS = "libxml2 glib-2.0 gtk+ libglade gtkhtml2 curl gconf js libowl"
4DESCRIPTION = "Web is a multi-platform web browsing application."
5PR = "r4"
6
7PV = "0.0+git${SRCPV}"
8
9SRC_URI = "git://git.yoctoproject.org/web-sato;protocol=git \
10 file://owl-window-menu.patch \
11 file://makefile-whitespace.patch \
12 "
13
14LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
15
16S = "${WORKDIR}/git"
17
18do_unpack_append () {
19 bb.build.exec_func('do_remove_patches', d)
20}
21
22do_remove_patches () {
23 rm -rf ${S}/patches
24}
25
26inherit autotools pkgconfig gconf
27