summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/web/web-webkit_git.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-08-25 11:20:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-02 18:15:29 +0100
commit99666e772dd50767295294a5686710e6e2a49851 (patch)
tree94af09055008a86accc352dc4fd65c82ad15c5f3 /meta/recipes-sato/web/web-webkit_git.bb
parent06a89cb47da39fb9bb29e23cfb1751258391aeb2 (diff)
downloadpoky-99666e772dd50767295294a5686710e6e2a49851.tar.gz
o-hand recipes: convert from svn.o-hand.org to git.yoctoproject.org
(From OE-Core rev: 4e7218c19775ef81caed27742e9d203af10b7416) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/web/web-webkit_git.bb')
-rw-r--r--meta/recipes-sato/web/web-webkit_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-sato/web/web-webkit_git.bb b/meta/recipes-sato/web/web-webkit_git.bb
new file mode 100644
index 0000000000..2af12bc392
--- /dev/null
+++ b/meta/recipes-sato/web/web-webkit_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Multi-platform web browsing application."
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
7
8SECTION = "x11"
9DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
10
11# To access https web pages
12RRECOMMENDS_${PN} += "glib-networking"
13
14SRCREV = "0f7019acd9db5383c732d0524c7c3a5eaec9be2b"
15PV = "0.1+git${SRCPV}"
16PR = "r0"
17
18SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
19 file://link-with-g++.patch \
20 file://make-382.patch"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF = "--enable-libowl"
25
26inherit autotools pkgconfig gconf
27
28do_configure_prepend() {
29 touch ${S}/src/dummy.cpp
30}
31
32FILES_${PN} += "${datadir}/web2"