summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/tasks/task-core.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-20 17:25:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-21 00:29:30 +0100
commit6e95cb246f39e4d49d46761b9a7d51c858ac7e9d (patch)
tree1646acfdc315d3dfcc2516a6f49509ba7f633fae /meta/recipes-sato/tasks/task-core.bb
parent4d609d502161137620c4b1901cc225f9e871c3dc (diff)
downloadpoky-6e95cb246f39e4d49d46761b9a7d51c858ac7e9d.tar.gz
Rename poky-image-* -> core-image-* and task-poky-* -> task-core-*
(From OE-Core rev: 560b04181d8f51d189b99f01a72f17210dadf7a3) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/tasks/task-core.bb')
-rw-r--r--meta/recipes-sato/tasks/task-core.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-sato/tasks/task-core.bb b/meta/recipes-sato/tasks/task-core.bb
new file mode 100644
index 0000000000..a595ad71ae
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-core.bb
@@ -0,0 +1,73 @@
1#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Tasks for OpenedHand Poky"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9PR = "r34"
10
11PACKAGES = "\
12 task-core-apps-console \
13 task-core-apps-console-dbg \
14 task-core-apps-console-dev \
15 task-core-apps-x11-core \
16 task-core-apps-x11-core-dbg \
17 task-core-apps-x11-core-dev \
18 task-core-apps-x11-games \
19 task-core-apps-x11-games-dbg \
20 task-core-apps-x11-games-dev \
21 task-core-x11-base \
22 task-core-x11-base-dbg \
23 task-core-x11-base-dev \
24 "
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28XSERVER ?= "xserver-kdrive-fbdev"
29
30ALLOW_EMPTY = "1"
31
32SPLASH ?= "psplash"
33
34# pcmanfm doesn't work on mips/powerpc
35FILEMANAGER ?= "pcmanfm"
36FILEMANAGER_mips ?= ""
37
38RDEPENDS_task-core-apps-console = "\
39 avahi-daemon \
40 dbus \
41 portmap \
42 ${SPLASH}"
43
44
45RDEPENDS_task-core-x11-base = "\
46 dbus \
47 pointercal \
48 matchbox-wm \
49 matchbox-keyboard \
50 matchbox-keyboard-applet \
51 matchbox-keyboard-im \
52 matchbox-panel-2 \
53 matchbox-desktop \
54 matchbox-session \
55 ${XSERVER} \
56 x11-common \
57 xserver-nodm-init \
58 liberation-fonts \
59 xauth \
60 xhost \
61 xset \
62 xrandr"
63
64
65RDEPENDS_task-core-apps-x11-core = "\
66 leafpad \
67 ${FILEMANAGER} \
68 matchbox-terminal \
69 screenshot"
70
71
72RDEPENDS_task-core-apps-x11-games = "\
73 oh-puzzles"