summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/tasks/task-core-x11.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-09-14 17:19:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:23:57 +0100
commit8c310ee0a94a7e15d815a2719272ffc704e857b0 (patch)
tree1e8a108c25c5cb4ae395b40a264eda7ac4dedff3 /meta/recipes-sato/tasks/task-core-x11.bb
parentd1f4cebf7ec76e34134dc2d1e8108eee1da36b40 (diff)
downloadpoky-8c310ee0a94a7e15d815a2719272ffc704e857b0.tar.gz
task-core: split into task-core-console and task-core-x11
[YOCTO #1481] Since tasks are referred to almost exclusively via RDEPENDS, and bitbake will build an entire task recipe when only one of its task packages are actually needed, building a console-only image that uses task-core-apps-console (or less directly, has apps-console in its IMAGE_FEATURES) will cause a build of a whole list of X11 applications that aren't needed. Splitting the task-core recipe into X11 and console portions prevents this issue. (From OE-Core rev: 07407baafb728c5ae1bb283f5b02a2ac773360bc) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/tasks/task-core-x11.bb')
-rw-r--r--meta/recipes-sato/tasks/task-core-x11.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-sato/tasks/task-core-x11.bb b/meta/recipes-sato/tasks/task-core-x11.bb
new file mode 100644
index 0000000000..26d550add2
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-core-x11.bb
@@ -0,0 +1,62 @@
1#
2# Copyright (C) 2011 Intel Corporation
3#
4
5DESCRIPTION = "Tasks for core X11 applications"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9PR = "r35"
10
11PACKAGES = "\
12 task-core-apps-x11-core \
13 task-core-apps-x11-core-dbg \
14 task-core-apps-x11-core-dev \
15 task-core-apps-x11-games \
16 task-core-apps-x11-games-dbg \
17 task-core-apps-x11-games-dev \
18 task-core-x11-base \
19 task-core-x11-base-dbg \
20 task-core-x11-base-dev \
21 "
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25XSERVER ?= "xserver-kdrive-fbdev"
26
27ALLOW_EMPTY = "1"
28
29# pcmanfm doesn't work on mips/powerpc
30FILEMANAGER ?= "pcmanfm"
31FILEMANAGER_mips ?= ""
32
33
34RDEPENDS_task-core-x11-base = "\
35 dbus \
36 pointercal \
37 matchbox-wm \
38 matchbox-keyboard \
39 matchbox-keyboard-applet \
40 matchbox-keyboard-im \
41 matchbox-panel-2 \
42 matchbox-desktop \
43 matchbox-session \
44 ${XSERVER} \
45 x11-common \
46 xserver-nodm-init \
47 liberation-fonts \
48 xauth \
49 xhost \
50 xset \
51 xrandr"
52
53
54RDEPENDS_task-core-apps-x11-core = "\
55 leafpad \
56 ${FILEMANAGER} \
57 matchbox-terminal \
58 screenshot"
59
60
61RDEPENDS_task-core-apps-x11-games = "\
62 oh-puzzles"