summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-26 19:14:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 16:49:12 +0000
commit1b26bce9675f1beb3d0370f49fc5ed9709c979f6 (patch)
tree7a24e783ae68cc1c26c0c8ba16c4e1e53af97ac7 /meta/recipes-sato/settings-daemon/settings-daemon_git.bb
parent5612838d7e7f958633d211a186ab1cbab2803805 (diff)
downloadpoky-1b26bce9675f1beb3d0370f49fc5ed9709c979f6.tar.gz
matchbox: Convert all the matchbox components' repo from svn to git including:
matchbox-wm matchbox-panel-2 matchbox-terminal matchbox-config-gtk matchbox-stroke matchbox-desktop matchbox-keyboard matchbox-themes-extra libfakekey settings-daemon Also remove some old recipes. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato/settings-daemon/settings-daemon_git.bb')
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_git.bb b/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
new file mode 100644
index 0000000000..f7dc86fec9
--- /dev/null
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Settings-daemon provides a bridge between gconf and xsettings"
2HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4LICENSE = "MIT-style"
5LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
6 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
7DEPENDS = "gconf glib-2.0 gtk+"
8SECTION = "x11"
9PV = "0.0+git${SRCPV}"
10
11PR = "r0"
12
13SRC_URI = "git://git.pokylinux.org/xsettings-daemon;protocol=git \
14 file://addsoundkeys.patch;apply=yes \
15 file://70settings-daemon.sh \
16 file://dso_linking_change_build_fix.patch"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig gconf
21
22FILES_${PN} = "${bindir}/* ${sysconfdir}"
23
24do_install_append () {
25 install -d ${D}/${sysconfdir}/X11/Xsession.d
26 install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/
27}