summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-15 15:20:02 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:28:50 +0100
commit16fa164d156bb974ae2b5aa9f9be17c02cc8d2f2 (patch)
tree49e9e7f6529117990c8212c1a99ce2f70eef166f /meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
parent8bf2692b1bfa8ce090d0b7de465eb64e670c9457 (diff)
downloadpoky-16fa164d156bb974ae2b5aa9f9be17c02cc8d2f2.tar.gz
sato-screenshot: Upgrade 0.2 -> 0.3
(From OE-Core rev: e9ff03c4af75914b9abb5c5237e6a08aa631d332) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb')
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
new file mode 100644
index 0000000000..f3305aef78
--- /dev/null
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Ultra-simple screen capture utility, aimed at handheld devices"
2HOMEPAGE = "http://www.o-hand.com"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://main.c;endline=9;md5=023e14d6404d0a961eb97cbd011fc141 \
8 file://screenshot-ui.h;endline=9;md5=638d9ffa83e9325a36df224166ed6ad0"
9
10DEPENDS = "matchbox-panel-2 gtk+3"
11
12# SRCREV tagged 0.3
13SRCREV = "9250fa5a012d84ff45984e8c4345ee7635227756"
14SRC_URI = "git://git.yoctoproject.org/screenshot"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig distro_features_check
20
21FILES_${PN} += "${libdir}/matchbox-panel/*.so"
22
23do_install_append () {
24 rm ${D}${libdir}/matchbox-panel/*.la
25}
26
27# The matchbox-panel-2 requires x11 in DISTRO_FEATURES
28REQUIRED_DISTRO_FEATURES = "x11"