diff options
author | Constantin Musca <constantinx.musca@intel.com> | 2013-01-10 10:00:59 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-01-10 23:49:40 +0000 |
commit | d777af8425b24862fd758b0e0f85e02687fe439c (patch) | |
tree | 17b347ec2eeff5f97a2ca6f7bc8f938889d78c11 /meta/recipes-sato/puzzles/puzzles_r9733.bb | |
parent | 4739031722ec9a99b33be0d0aef8fb4d3d094d43 (diff) | |
download | poky-d777af8425b24862fd758b0e0f85e02687fe439c.tar.gz |
puzzles: upgrade to r9733
(From OE-Core rev: 418312a2523f5e1fd231d215475250168f17fa58)
Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9733.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/puzzles_r9733.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9733.bb b/meta/recipes-sato/puzzles/puzzles_r9733.bb new file mode 100644 index 0000000000..5ab316169e --- /dev/null +++ b/meta/recipes-sato/puzzles/puzzles_r9733.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION="Simon Tatham's Portable Puzzle Collection" | ||
2 | HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" | ||
3 | |||
4 | DEPENDS = "gtk+ libxt" | ||
5 | PR = "r0" | ||
6 | MOD_PV = "${@d.getVar('PV',1)[1:]}" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=31790deb1e1aac4626e7d1bc04587eb0" | ||
10 | |||
11 | # Upstream updates puzzles.tar.gz for the new release, so checksums seem to be changing regularly right now | ||
12 | SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV};protocol=svn" | ||
13 | S = "${WORKDIR}/${BPN}" | ||
14 | |||
15 | #SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz" | ||
16 | #SRC_URI[md5sum] = "9d84769562007e0f99edac77a3b2d27c" | ||
17 | #SRC_URI[sha256sum] = "b688b5196f8406a23741e973178bdde78e5f8af4d2a88c33ca1ae1cc1a069d15" | ||
18 | #S = "${WORKDIR}/${BPN}-${PV}" | ||
19 | |||
20 | do_configure () { | ||
21 | ./mkfiles.pl | ||
22 | } | ||
23 | |||
24 | do_compile_prepend = " \ | ||
25 | export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \ | ||
26 | export XLFLAGS=-lm \ | ||
27 | export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; " | ||
28 | |||
29 | FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*" | ||
30 | FILES_${PN}-dbg += "${prefix}/games/.debug" | ||
31 | |||
32 | do_install () { | ||
33 | rm -rf ${D}/* | ||
34 | export prefix=${D} | ||
35 | export DESTDIR=${D} | ||
36 | install -d ${D}/${prefix}/ | ||
37 | install -d ${D}/${prefix}/games/ | ||
38 | oe_runmake install | ||
39 | |||
40 | install -d ${D}/${datadir}/ | ||
41 | install -d ${D}/${datadir}/applications/ | ||
42 | |||
43 | cd ${D}/${prefix}/games | ||
44 | for prog in *; do | ||
45 | if [ -x $prog ]; then | ||
46 | # Convert prog to Title Case | ||
47 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
48 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
49 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
50 | [Desktop Entry] | ||
51 | Name=$title | ||
52 | Exec=${prefix}/games/$prog | ||
53 | Icon=applications-games | ||
54 | Terminal=false | ||
55 | Type=Application | ||
56 | Categories=Game; | ||
57 | StartupNotify=true | ||
58 | X-MB-SingleInstance=true | ||
59 | STOP | ||
60 | fi | ||
61 | done | ||
62 | } | ||