diff options
author | Zhai Edwin <edwin.zhai@intel.com> | 2010-11-30 16:34:52 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-12-06 22:02:25 +0000 |
commit | 48ba76afdf360261f91eccf0deee5a0767adf8b5 (patch) | |
tree | 95949e27c2927bbdc1f16f269f19c47a6366bdd2 /meta/recipes-sato/puzzles/puzzles_r9023.bb | |
parent | ccdd26d18ad4cb50e3f74ba0aead20776da05d1f (diff) | |
download | poky-48ba76afdf360261f91eccf0deee5a0767adf8b5.tar.gz |
puzzles: Update to svn r9023
Removed makedist_hack.patch, as makedist.sh is no longer exist in upstream and
mkfiles.pl is called directly now.
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9023.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/puzzles_r9023.bb | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9023.bb b/meta/recipes-sato/puzzles/puzzles_r9023.bb new file mode 100644 index 0000000000..e51bd7a560 --- /dev/null +++ b/meta/recipes-sato/puzzles/puzzles_r9023.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | DESCRIPTION="Simon Tatham's Portable Puzzle Collection" | ||
2 | HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" | ||
3 | |||
4 | DEPENDS = "gtk+ libxt" | ||
5 | PR = "r0" | ||
6 | MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5" | ||
10 | |||
11 | SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz" | ||
12 | #SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}" | ||
13 | |||
14 | S = "${WORKDIR}/${PN}-${PV}" | ||
15 | |||
16 | do_configure () { | ||
17 | ./mkfiles.pl | ||
18 | } | ||
19 | |||
20 | do_compile_prepend = " \ | ||
21 | export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \ | ||
22 | export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; " | ||
23 | |||
24 | FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*" | ||
25 | FILES_${PN}-dbg += "${prefix}/games/.debug" | ||
26 | |||
27 | do_install () { | ||
28 | rm -rf ${D}/* | ||
29 | export prefix=${D} | ||
30 | export DESTDIR=${D} | ||
31 | install -d ${D}/${prefix}/ | ||
32 | install -d ${D}/${prefix}/games/ | ||
33 | oe_runmake install | ||
34 | |||
35 | install -d ${D}/${datadir}/ | ||
36 | install -d ${D}/${datadir}/applications/ | ||
37 | |||
38 | cd ${D}/${prefix}/games | ||
39 | for prog in *; do | ||
40 | if [ -x $prog ]; then | ||
41 | # Convert prog to Title Case | ||
42 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
43 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
44 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
45 | [Desktop Entry] | ||
46 | Name=$title | ||
47 | Exec=${prefix}/games/$prog | ||
48 | Icon=applications-games | ||
49 | Terminal=false | ||
50 | Type=Application | ||
51 | Categories=Game; | ||
52 | StartupNotify=true | ||
53 | X-MB-SingleInstance=true | ||
54 | STOP | ||
55 | fi | ||
56 | done | ||
57 | } | ||