summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r7593.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-11-30 16:34:52 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-06 22:02:25 +0000
commit48ba76afdf360261f91eccf0deee5a0767adf8b5 (patch)
tree95949e27c2927bbdc1f16f269f19c47a6366bdd2 /meta/recipes-sato/puzzles/puzzles_r7593.bb
parentccdd26d18ad4cb50e3f74ba0aead20776da05d1f (diff)
downloadpoky-48ba76afdf360261f91eccf0deee5a0767adf8b5.tar.gz
puzzles: Update to svn r9023
Removed makedist_hack.patch, as makedist.sh is no longer exist in upstream and mkfiles.pl is called directly now. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r7593.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r7593.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r7593.bb b/meta/recipes-sato/puzzles/puzzles_r7593.bb
deleted file mode 100644
index 7471352b2d..0000000000
--- a/meta/recipes-sato/puzzles/puzzles_r7593.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1
2DEPENDS = "gtk+ libxt"
3PR = "r8"
4MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}"
5
6LICENSE = "MIT"
7
8#SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
9SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV} \
10 file://makedist_hack.patch;patch=1"
11
12S = "${WORKDIR}/${PN}"
13
14do_configure () {
15 ./makedist.sh ${MOD_PV}
16}
17
18do_compile_prepend = " \
19 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
20 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
21
22FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
23FILES_${PN}-dbg += "${prefix}/games/.debug"
24
25do_install () {
26 rm -rf ${D}/*
27 export prefix=${D}
28 export DESTDIR=${D}
29 install -d ${D}/${prefix}/
30 install -d ${D}/${prefix}/games/
31 oe_runmake install
32
33 install -d ${D}/${datadir}/
34 install -d ${D}/${datadir}/applications/
35
36 cd ${D}/${prefix}/games
37 for prog in *; do
38 if [ -x $prog ]; then
39 # Convert prog to Title Case
40 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
41 echo "making ${D}/${datadir}/applications/$prog.desktop"
42 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
43[Desktop Entry]
44Name=$title
45Exec=${prefix}/games/$prog
46Icon=applications-games
47Terminal=false
48Type=Application
49Categories=Game;
50StartupNotify=true
51X-MB-SingleInstance=true
52STOP
53 fi
54 done
55}