diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-09 15:00:01 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-10 11:51:19 +0000 |
commit | c8dee9b92dfd545852ecac8dc2adfc95ac02e957 (patch) | |
tree | 5f1b86954646a0f3bb914407994388a6a4346769 /meta/recipes-sato/puzzles/oh-puzzles_git.bb | |
parent | 5d3860f4a8abb8e95442b04f8b84a333af362fcd (diff) | |
download | poky-c8dee9b92dfd545852ecac8dc2adfc95ac02e957.tar.gz |
Convert to use direct access to the data store (instead of bb.data.*Var*())
This is the result of running the following over the metadata:
sed \
-e 's:bb.data.\(setVar([^,()]*,[^,()]*\), *\([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,()]*,[^,()]*,[^,()]*\), *\([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,()]*\), *\([^(), ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,()]*,[^,()]*\), *\([^(), ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,()]*,[^,()]*\), *\([^() ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,()]*\), *\([^) ]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
(From OE-Core rev: b22831fd63164c4db9c0b72934d7d734a6585251)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/oh-puzzles_git.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/oh-puzzles_git.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb index 6d95d79e8c..c2e7622245 100644 --- a/meta/recipes-sato/puzzles/oh-puzzles_git.bb +++ b/meta/recipes-sato/puzzles/oh-puzzles_git.bb | |||
@@ -61,10 +61,10 @@ FILES_${PN}-extra = "/usr/games/ /usr/share/applications /etc/gconf/schemas" | |||
61 | python __anonymous () { | 61 | python __anonymous () { |
62 | import bb | 62 | import bb |
63 | var = bb.data.expand("FILES_${PN}", d, 1) | 63 | var = bb.data.expand("FILES_${PN}", d, 1) |
64 | data = bb.data.getVar(var, d, 1) | 64 | data = d.getVar(var, 1) |
65 | for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"): | 65 | for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"): |
66 | data = data + " /usr/games/%s" % name | 66 | data = data + " /usr/games/%s" % name |
67 | data = data + " /usr/share/applications/%s.desktop" % name | 67 | data = data + " /usr/share/applications/%s.desktop" % name |
68 | data = data + " /etc/gconf/schemas/%s.schemas" % name | 68 | data = data + " /etc/gconf/schemas/%s.schemas" % name |
69 | bb.data.setVar(var, data, d) | 69 | d.setVar(var, data) |
70 | } | 70 | } |