diff options
author | Saul Wold <sgw@linux.intel.com> | 2011-08-25 11:20:21 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-09-02 18:15:29 +0100 |
commit | 99666e772dd50767295294a5686710e6e2a49851 (patch) | |
tree | 94af09055008a86accc352dc4fd65c82ad15c5f3 /meta/recipes-sato/puzzles/oh-puzzles_git.bb | |
parent | 06a89cb47da39fb9bb29e23cfb1751258391aeb2 (diff) | |
download | poky-99666e772dd50767295294a5686710e6e2a49851.tar.gz |
o-hand recipes: convert from svn.o-hand.org to git.yoctoproject.org
(From OE-Core rev: 4e7218c19775ef81caed27742e9d203af10b7416)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/oh-puzzles_git.bb')
-rw-r--r-- | meta/recipes-sato/puzzles/oh-puzzles_git.bb | 70 |
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb new file mode 100644 index 0000000000..6d95d79e8c --- /dev/null +++ b/meta/recipes-sato/puzzles/oh-puzzles_git.bb | |||
@@ -0,0 +1,70 @@ | |||
1 | DESCRIPTION = "Portable Puzzle Collection" | ||
2 | HOMEPAGE = "http://o-hand.com/" | ||
3 | BUGTRACKER = "http://bugzilla.openedhand.com/" | ||
4 | |||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENCE;md5=f56ec6772dd1c7c367067bbea8ea1675 \ | ||
7 | file://src/tree234.h;endline=28;md5=a188e6d250430ca094a54a82f48472a7 \ | ||
8 | file://src/tree234.c;endline=28;md5=b4feb1976feebf8f1379093ed52f2945" | ||
9 | |||
10 | SECTION = "x11" | ||
11 | DEPENDS = "gtk+ gconf intltool-native librsvg" | ||
12 | DEPENDS_append_poky = " libowl" | ||
13 | |||
14 | SRCREV = "92f1a20e4b72eed7a35b00984d9793b51dc2fb3b" | ||
15 | PV = "0.2+git${SRCPV}" | ||
16 | PR = "r10" | ||
17 | |||
18 | SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git" | ||
19 | SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;striplevel=0 " | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | inherit autotools pkgconfig | ||
24 | |||
25 | bindir = "/usr/games" | ||
26 | |||
27 | EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1" | ||
28 | |||
29 | do_install_append () { | ||
30 | install -d ${D}/${datadir}/applications/ | ||
31 | |||
32 | cd ${D}/${prefix}/games | ||
33 | for prog in *; do | ||
34 | if [ -x $prog ]; then | ||
35 | # Convert prog to Title Case | ||
36 | title=$(echo $prog | sed 's/\(^\| \)./\U&/g') | ||
37 | echo "making ${D}/${datadir}/applications/$prog.desktop" | ||
38 | cat <<STOP > ${D}/${datadir}/applications/$prog.desktop | ||
39 | [Desktop Entry] | ||
40 | Name=$title | ||
41 | Exec=${prefix}/games/$prog | ||
42 | Icon=applications-games | ||
43 | Terminal=false | ||
44 | Type=Application | ||
45 | Categories=Game; | ||
46 | StartupNotify=true | ||
47 | X-MB-SingleInstance=true | ||
48 | Comment=Play $title. | ||
49 | STOP | ||
50 | fi | ||
51 | done | ||
52 | } | ||
53 | |||
54 | PACKAGES += ${PN}-extra | ||
55 | RDEPENDS_${PN}-extra += "oh-puzzles" | ||
56 | |||
57 | FILES_${PN} = "/usr/share/pixmaps /usr/share/oh-puzzles/" | ||
58 | FILES_${PN}-dbg += "/usr/games/.debug/*" | ||
59 | FILES_${PN}-extra = "/usr/games/ /usr/share/applications /etc/gconf/schemas" | ||
60 | |||
61 | python __anonymous () { | ||
62 | import bb | ||
63 | var = bb.data.expand("FILES_${PN}", d, 1) | ||
64 | data = bb.data.getVar(var, d, 1) | ||
65 | for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"): | ||
66 | data = data + " /usr/games/%s" % name | ||
67 | data = data + " /usr/share/applications/%s.desktop" % name | ||
68 | data = data + " /etc/gconf/schemas/%s.schemas" % name | ||
69 | bb.data.setVar(var, data, d) | ||
70 | } | ||