summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-24 15:46:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:33:04 +0000
commitb19dbe5365fb37f74268f0f898d4e8b11bfcff0a (patch)
tree9efcf66ff018b65dce16d655f5f83eb5afad64be /meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb
parent6b4160892346facb2f786b6a9dd576ca6a8a879b (diff)
downloadpoky-b19dbe5365fb37f74268f0f898d4e8b11bfcff0a.tar.gz
pcmanfm: update to 1.2.4
(From OE-Core rev: 32ddcc1be9005d472dd1aa2a0a7aa87665e6ed88) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb
new file mode 100644
index 0000000000..a6b0aacd29
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.2.4.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Fast lightweight tabbed filemanager"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3
4LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
6 file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
7 file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
8
9SECTION = "x11"
10DEPENDS = "gtk+ startup-notification libfm intltool-native gettext-native"
11DEPENDS_append_poky = " libowl"
12
13
14COMPATIBLE_HOST = '(x86_64.*|i.86.*|aarch64.*|arm.*|mips.*|powerpc.*|sh.*)-(linux|freebsd.*)'
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.xz \
17 file://gnome-fs-directory.png \
18 file://gnome-fs-regular.png \
19 file://gnome-mime-text-plain.png \
20 file://emblem-symbolic-link.png \
21 file://no-desktop.patch"
22
23SRC_URI[md5sum] = "19764c2f59653724c8713e0064fa6829"
24SRC_URI[sha256sum] = "38cdbb5f01d24483b41b8e6846e4aa66a5751bb3982a8618899e88a853dbe313"
25
26UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/pcmanfm/files/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/PCManFM/"
27
28inherit autotools pkgconfig distro_features_check
29
30# The startup-notification requires x11 in DISTRO_FEATURES
31REQUIRED_DISTRO_FEATURES = "x11"
32
33do_install_append () {
34 install -d ${D}/${datadir}
35 install -d ${D}/${datadir}/pixmaps/
36
37 install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
38}
39
40FILES_${PN} += "${libdir}/pcmanfm"
41
42RRECOMMENDS_${PN} += "adwaita-icon-theme"