summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:52:55 +0100
commit272cb74d70686cb7f72005dc25e02f38b46ecd57 (patch)
tree3a5e4cb0c9a2e407b2d04c78b1eb51d0f429ca64 /meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
parentf1df3f828bfc9e70bf8cf5a7c2e2cf216944785a (diff)
downloadpoky-272cb74d70686cb7f72005dc25e02f38b46ecd57.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. (From OE-Core rev: 424dcf7046e4ad09dcc664eb1992201195247fcf) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/packagegroups/packagegroup-core-x11.bb')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
new file mode 100644
index 0000000000..4c16c461a3
--- /dev/null
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
@@ -0,0 +1,68 @@
1#
2# Copyright (C) 2011 Intel Corporation
3#
4
5DESCRIPTION = "Tasks for core X11 applications"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9PR = "r36"
10
11PACKAGES = "\
12 packagegroup-core-apps-x11-core \
13 packagegroup-core-apps-x11-core-dbg \
14 packagegroup-core-apps-x11-core-dev \
15 packagegroup-core-apps-x11-games \
16 packagegroup-core-apps-x11-games-dbg \
17 packagegroup-core-apps-x11-games-dev \
18 packagegroup-core-x11-base \
19 packagegroup-core-x11-base-dbg \
20 packagegroup-core-x11-base-dev \
21 "
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
26
27ALLOW_EMPTY = "1"
28
29# pcmanfm doesn't work on mips/powerpc
30FILEMANAGER ?= "pcmanfm"
31FILEMANAGER_mips ?= ""
32
33# xserver-common, x11-common
34VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
35
36# elsa, xserver-nodm-init
37VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
38
39
40RDEPENDS_packagegroup-core-x11-base = "\
41 dbus \
42 pointercal \
43 matchbox-wm \
44 matchbox-keyboard \
45 matchbox-keyboard-applet \
46 matchbox-keyboard-im \
47 matchbox-panel-2 \
48 matchbox-desktop \
49 matchbox-session \
50 ${XSERVER} \
51 ${VIRTUAL-RUNTIME_xserver_common} \
52 ${VIRTUAL-RUNTIME_graphical_init_manager} \
53 liberation-fonts \
54 xauth \
55 xhost \
56 xset \
57 xrandr"
58
59
60RDEPENDS_packagegroup-core-apps-x11-core = "\
61 leafpad \
62 ${FILEMANAGER} \
63 matchbox-terminal \
64 sato-screenshot"
65
66
67RDEPENDS_packagegroup-core-apps-x11-games = "\
68 oh-puzzles"