summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/owl-video-widget/owl-video_git.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-08-25 11:20:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-02 18:15:29 +0100
commit99666e772dd50767295294a5686710e6e2a49851 (patch)
tree94af09055008a86accc352dc4fd65c82ad15c5f3 /meta/recipes-sato/owl-video-widget/owl-video_git.bb
parent06a89cb47da39fb9bb29e23cfb1751258391aeb2 (diff)
downloadpoky-99666e772dd50767295294a5686710e6e2a49851.tar.gz
o-hand recipes: convert from svn.o-hand.org to git.yoctoproject.org
(From OE-Core rev: 4e7218c19775ef81caed27742e9d203af10b7416) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/owl-video-widget/owl-video_git.bb')
-rw-r--r--meta/recipes-sato/owl-video-widget/owl-video_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-sato/owl-video-widget/owl-video_git.bb b/meta/recipes-sato/owl-video-widget/owl-video_git.bb
new file mode 100644
index 0000000000..3ecb82e78b
--- /dev/null
+++ b/meta/recipes-sato/owl-video-widget/owl-video_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "OpenedHand Widget Library video widget"
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.o-hand.com/"
4LICENSE = "LGPLv2.1 & GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ac14b7ca45afea5af040da54db270eb0 \
6 file://src/video.c;endline=22;md5=e8e9f23c3691c11af7d8fc03264ca9da \
7 file://src/bacon-volume.c;endline=20;md5=798804562b24e30bac482ba91c45e46d"
8SECTION = "x11"
9DEPENDS = "libowl-av"
10
11SRCREV = "f133472318970796fae1ea3e98ac062156768baf"
12PV = "0.1+git${SRCPV}"
13PR = "r0"
14
15S = "${WORKDIR}/git"
16
17SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
18 file://gtk_multithread_safe.patch \
19 file://owl-video-widget.png \
20 file://stock_media-play.png \
21 file://stock_volume-0.png \
22 file://stock_volume-min.png \
23 file://stock_volume-med.png \
24 file://stock_volume-max.png \
25 file://owl-video-widget.desktop \
26 file://make-382.patch"
27
28inherit autotools pkgconfig
29
30do_install_append () {
31 install -d ${D}/${datadir}/pixmaps
32 install -m 0644 ${WORKDIR}/stock_media-play.png ${D}/${datadir}/pixmaps
33 install -m 0644 ${WORKDIR}/stock_volume-0.png ${D}/${datadir}/pixmaps
34 install -m 0644 ${WORKDIR}/stock_volume-min.png ${D}/${datadir}/pixmaps
35 install -m 0644 ${WORKDIR}/stock_volume-med.png ${D}/${datadir}/pixmaps
36 install -m 0644 ${WORKDIR}/stock_volume-max.png ${D}/${datadir}/pixmaps
37 install -m 0644 ${WORKDIR}/owl-video-widget.png ${D}/${datadir}/pixmaps
38
39 install -d ${D}/${datadir}/applications
40 install -m 0644 ${WORKDIR}/owl-video-widget.desktop ${D}/${datadir}/applications
41}