summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-26 19:14:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 16:49:12 +0000
commit1b26bce9675f1beb3d0370f49fc5ed9709c979f6 (patch)
tree7a24e783ae68cc1c26c0c8ba16c4e1e53af97ac7 /meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
parent5612838d7e7f958633d211a186ab1cbab2803805 (diff)
downloadpoky-1b26bce9675f1beb3d0370f49fc5ed9709c979f6.tar.gz
matchbox: Convert all the matchbox components' repo from svn to git including:
matchbox-wm matchbox-panel-2 matchbox-terminal matchbox-config-gtk matchbox-stroke matchbox-desktop matchbox-keyboard matchbox-themes-extra libfakekey settings-daemon Also remove some old recipes. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
new file mode 100644
index 0000000000..256b5a22da
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "A simple GTK+ based panel for handheld devices."
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \
8 file://applets/startup/startup.c;endline=22;md5=b0a64fbef3097d79f8264e6907a98f03"
9
10PRIORITY = "optional"
11DEPENDS = "gtk+ startup-notification dbus dbus-glib"
12DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
13DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
14
15PV = "0.0+git${SRCPV}"
16PR = "r0"
17
18RPROVIDES_${PN} = "matchbox-panel"
19RREPLACES_${PN} = "matchbox-panel"
20RCONFLICTS_${PN} = "matchbox-panel"
21
22SRC_URI = "git://git.pokylinux.org/${PN};protocol=git \
23 file://startup_fix.diff;patch=1"
24
25EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
26EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
27EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
28
29S = "${WORKDIR}/git"
30
31FILES_${PN} += "${libdir}/matchbox-panel/*.so \
32 ${datadir}/matchbox-panel/brightness/*.png \
33 ${datadir}/matchbox-panel/startup/*.png "
34FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
35
36inherit autotools pkgconfig