summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-26 19:14:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 16:49:12 +0000
commit1b26bce9675f1beb3d0370f49fc5ed9709c979f6 (patch)
tree7a24e783ae68cc1c26c0c8ba16c4e1e53af97ac7 /meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
parent5612838d7e7f958633d211a186ab1cbab2803805 (diff)
downloadpoky-1b26bce9675f1beb3d0370f49fc5ed9709c979f6.tar.gz
matchbox: Convert all the matchbox components' repo from svn to git including:
matchbox-wm matchbox-panel-2 matchbox-terminal matchbox-config-gtk matchbox-stroke matchbox-desktop matchbox-keyboard matchbox-themes-extra libfakekey settings-daemon Also remove some old recipes. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
new file mode 100644
index 0000000000..245f999335
--- /dev/null
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
@@ -0,0 +1,61 @@
1DESCRIPTION = "Matchbox virtual keyboard for X11"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://src/matchbox-keyboard.h;endline=20;md5=4ba16ff913ad245dd6d95a6c67f72526 \
8 file://applet/applet.c;endline=20;md5=e9201b3efa0a81a160b88d6feb5cf75b"
9
10DEPENDS = "libfakekey expat libxft gtk+ matchbox-panel-2"
11RDEPENDS_${PN} = "formfactor dbus-wait"
12SECTION = "x11"
13PV = "0.0+git${SRCPV}"
14PR = "r0"
15
16SRC_URI = "git://git.pokylinux.org/${PN};protocol=git \
17 file://configure_fix.patch;patch=1;maxrev=1819 \
18 file://single-instance.patch;patch=1 \
19 file://80matchboxkeyboard.shbg"
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig gettext
24
25EXTRA_OECONF = "--disable-cairo --enable-gtk-im --enable-applet"
26
27PACKAGES += "matchbox-keyboard-im matchbox-keyboard-im-dbg \
28 matchbox-keyboard-applet matchbox-keyboard-applet-dbg"
29
30FILES_${PN} = "${bindir}/* \
31 ${sysconfdir} \
32 ${datadir}/applications \
33 ${datadir}/pixmaps \
34 ${datadir}/matchbox-keyboard"
35
36FILES_matchbox-keyboard-im = "${libdir}/gtk-2.0/*/immodules/*.so"
37FILES_matchbox-keyboard-im-dbg += "${libdir}/gtk-2.0/*/immodules/.debug"
38
39FILES_matchbox-keyboard-applet = "${libdir}/matchbox-panel/*.so"
40FILES_matchbox-keyboard-applet-dbg += "${libdir}/matchbox-panel/.debug"
41
42do_install_append () {
43 install -d ${D}/${sysconfdir}/X11/Xsession.d/
44 install -m 755 ${WORKDIR}/80matchboxkeyboard.shbg ${D}/${sysconfdir}/X11/Xsession.d/
45}
46
47pkg_postinst_matchbox-keyboard-im () {
48if [ "x$D" != "x" ]; then
49 exit 1
50fi
51
52gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
53}
54
55pkg_postrm_matchbox-keyboard-im () {
56if [ "x$D" != "x" ]; then
57 exit 1
58fi
59
60gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
61}