summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-15 15:20:03 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:28:50 +0100
commitb1d573bdc880426c14d8a6802a17e513af21d1a8 (patch)
tree62f80cfd885a55c422aa9e1e87f424361fc33bcf /meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb
parent16fa164d156bb974ae2b5aa9f9be17c02cc8d2f2 (diff)
downloadpoky-b1d573bdc880426c14d8a6802a17e513af21d1a8.tar.gz
matchbox-keyboard: Upgrade to 0.1.1
(From OE-Core rev: 9b4783572db0a7f4462c1ca6a7e6b95c319f3d19) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb
new file mode 100644
index 0000000000..465f1349af
--- /dev/null
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_0.1.1.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Matchbox virtual keyboard for X11"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4SECTION = "x11"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
8 file://src/matchbox-keyboard.h;endline=17;md5=9d6586c69e4a926f3cb0b4425f24ba3c \
9 file://applet/applet.c;endline=18;md5=4a0f721724746b14d95b51ddd42b95e7"
10
11DEPENDS = "libfakekey expat libxft"
12
13#SRCREV for 0.1.1
14SRCREV = "630d89068dc0a1e9199306d405cb32f892dfa4d3"
15SRC_URI = "git://git.yoctoproject.org/${BPN};branch=matchbox-keyboard-0-1 \
16 file://0001-desktop-file-Hide-the-keyboard-from-app-list.patch \
17 file://80matchboxkeyboard.sh"
18
19S = "${WORKDIR}/git"
20
21inherit autotools pkgconfig gettext gtk-immodules-cache distro_features_check
22
23# The libxft, libfakekey and matchbox-panel-2 requires x11 in DISTRO_FEATURES
24REQUIRED_DISTRO_FEATURES = "x11"
25
26EXTRA_OECONF = "--disable-cairo"
27
28PACKAGECONFIG ??= "gtk3-im applet"
29PACKAGECONFIG[applet] = "--enable-applet,--disable-applet,matchbox-panel-2"
30PACKAGECONFIG[gtk2-im] = "--enable-gtk-im,--disable-gtk-im,gtk+"
31PACKAGECONFIG[gtk3-im] = "--enable-gtk3-im,--disable-gtk3-im,gtk+3"
32
33PACKAGES += "${PN}-im ${PN}-applet"
34
35FILES_${PN} = "${bindir}/ \
36 ${sysconfdir} \
37 ${datadir}/applications \
38 ${datadir}/pixmaps \
39 ${datadir}/matchbox-keyboard"
40
41FILES_${PN}-im = "${libdir}/gtk-2.0/*/immodules/*.so \
42 ${libdir}/gtk-3.0/*/immodules/*.so"
43
44FILES_${PN}-applet = "${libdir}/matchbox-panel/*.so"
45
46
47do_install_append () {
48 install -d ${D}/${sysconfdir}/X11/Xsession.d/
49 install -m 755 ${WORKDIR}/80matchboxkeyboard.sh ${D}/${sysconfdir}/X11/Xsession.d/
50
51 rm -f ${D}${libdir}/gtk-2.0/*/immodules/*.la
52 rm -f ${D}${libdir}/gtk-3.0/*/immodules/*.la
53 rm -f ${D}${libdir}/matchbox-panel/*.la
54}
55
56GTKIMMODULES_PACKAGES = "${PN}-im"
57
58RDEPENDS_${PN} = "formfactor dbus-wait"
59RRECOMMENDS_${PN} = "${PN}-applet"