summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/eds/eds-dbus_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-sato/eds/eds-dbus_git.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/eds/eds-dbus_git.bb')
-rw-r--r--meta/recipes-sato/eds/eds-dbus_git.bb102
1 files changed, 102 insertions, 0 deletions
diff --git a/meta/recipes-sato/eds/eds-dbus_git.bb b/meta/recipes-sato/eds/eds-dbus_git.bb
new file mode 100644
index 0000000000..e11c91d5d7
--- /dev/null
+++ b/meta/recipes-sato/eds/eds-dbus_git.bb
@@ -0,0 +1,102 @@
1DESCRIPTION = "Evolution database backend server"
2HOMEPAGE = "http://www.gnome.org/projects/evolution/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2 & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
7 file://camel/camel.h;endline=24;md5=b02175c88f821224746b347a89731a2b \
8 file://libedataserver/e-data-server-util.h;endline=23;md5=9df8127bd8cfdc5469e938fc710d1f40 \
9 file://calendar/libecal/e-cal.h;endline=24;md5=5d496b9b6fd2a4fdbbfc31ef9455c9d0"
10
11DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib libsoup-2.4 libglade libical gnome-keyring gperf-native"
12
13PV = "2.30+git${SRCPV}"
14PR = "r0"
15
16SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
17 file://oh-contact.patch;patch=1;pnum=0 \
18 file://nossl.patch;patch=1 \
19 file://optional_imapx_provider.patch;patch=1 \
20 file://iconv-detect.h"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig
25
26# -ldb needs this on some platforms
27LDFLAGS += "-lpthread"
28
29# Parallel make shows many issues with this source code.
30# Current problems seem to be duplicate execution of the calander/backends
31# directories by make resulting in truncated/corrupt .la files
32PARALLEL_MAKE = ""
33
34do_configure_prepend () {
35 echo "EXTRA_DIST = " > ${S}/gtk-doc.make
36}
37
38do_configure_append () {
39 cp ${WORKDIR}/iconv-detect.h ${S}
40}
41
42EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
43 --with-soup --with-libdb=${STAGING_DIR_HOST}${prefix} \
44 --disable-smime --disable-ssl --disable-nntp --disable-gtk-doc --without-weather"
45
46PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \
47 libedata-book libedata-book-dev libedata-cal libedata-cal-dev \
48 libedataserver libedataserver-dev \
49 libedataserverui libedataserverui-dev"
50
51FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc"
52FILES_${PN}-dbg =+ "${libdir}/evolution-data-server-*/camel-providers/.debug \
53 ${libdir}/evolution-data-server*/extensions/.debug/"
54RRECOMMENDS_${PN}-dev += "libecal-dev libebook-dev"
55
56FILES_libcamel = "${libexecdir}/camel-* ${libdir}/libcamel-*.so.* \
57 ${libdir}/libcamel-provider-*.so.* \
58 ${libdir}/evolution-data-server-*/camel-providers/*.so \
59 ${libdir}/evolution-data-server-*/camel-providers/*.urls"
60FILES_libcamel-dev = "${libdir}/libcamel-*.so ${libdir}/libcamel-provider-*.so \
61 ${libdir}/pkgconfig/camel*pc \
62 ${includedir}/evolution-data-server*/camel"
63
64FILES_libebook = "${libdir}/libebook-*.so.*"
65FILES_libebook-dev = "${libdir}/libebook-1.2.so \
66 ${libdir}/pkgconfig/libebook-*.pc \
67 ${includedir}/evolution-data-server*/libebook/*.h"
68RRECOMMENDS_libebook = "libedata-book"
69
70FILES_libecal = "${libdir}/libecal-*.so.* \
71 ${datadir}/evolution-data-server-1.4/zoneinfo"
72FILES_libecal-dev = "${libdir}/libecal-*.so ${libdir}/pkgconfig/libecal-*.pc \
73 ${includedir}/evolution-data-server*/libecal/*.h \
74 ${includedir}/evolution-data-server*/libical/*.h"
75RRECOMMENDS_libecal = "libedata-cal tzdata"
76
77FILES_libedata-book = "${libexecdir}/e-addressbook-factory \
78 ${datadir}/dbus-1/services/*.AddressBook.service \
79 ${libdir}/libedata-book-*.so.* \
80 ${libdir}/evolution-data-server-*/extensions/libebook*.so"
81FILES_libedata-book-dev = "${libdir}/libedata-book-*.so \
82 ${libdir}/pkgconfig/libedata-book-*.pc \
83 ${includedir}/evolution-data-server-*/libedata-book"
84
85FILES_libedata-cal = "${libexecdir}/e-calendar-factory \
86 ${datadir}/dbus-1/services/*.Calendar.service \
87 ${libdir}/libedata-cal-*.so.* \
88 ${libdir}/evolution-data-server-*/extensions/libecal*.so"
89FILES_libedata-cal-dev = "${libdir}/libedata-cal-*.so \
90 ${libdir}/pkgconfig/libedata-cal-*.pc \
91 ${includedir}/evolution-data-server-*/libedata-cal"
92
93FILES_libedataserver = "${libdir}/libedataserver-*.so.*"
94FILES_libedataserver-dev = "${libdir}/libedataserver-*.so \
95 ${libdir}/pkgconfig/libedataserver-*.pc \
96 ${includedir}/evolution-data-server-*/libedataserver/*.h"
97
98FILES_libedataserverui = "${libdir}/libedataserverui-*.so.* ${datadir}/evolution-data-server-1.4/glade/*.glade"
99FILES_libedataserverui-dev = "${libdir}/libedataserverui-*.so \
100 ${libdir}/pkgconfig/libedataserverui-*.pc \
101 ${includedir}/evolution-data-server-*/libedataserverui/*.h"
102