summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-01 15:30:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-16 10:37:57 +0000
commita368478133ebe3f25ebe27b6b512fa65992a6cfa (patch)
treee85062f723f93c46394a3bd6cd994d20a4997aac /meta/recipes-rt/rt-tests/rt-tests_2.0.bb
parent77bc68c7ac62a2952c5504560e7013b4f11385dd (diff)
downloadpoky-a368478133ebe3f25ebe27b6b512fa65992a6cfa.tar.gz
rt-tests: fix the recipe version to match upstream
Upstream had a 2.0 tag for a while, then removed it and added a 1.1 tag :-/ Let's make it match to avoid confusion. There's only one new commit added, which adds a missing manpage. Also, update the outdated version comment in rt-tests.inc (From OE-Core rev: 799a7b74f1219040fe2d43dcdcd145600a9fecbd) (From OE-Core rev: 5a577f1aa4891646075a559fc94e52cfe34b96c9) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_2.0.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_2.0.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
deleted file mode 100644
index 4336c50d63..0000000000
--- a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
16 "
17# Do not install hwlatdetect
18EXTRA_OEMAKE += "PYLIB=''"
19
20do_install() {
21 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
22 INCLUDEDIR=${includedir}
23}
24
25do_install_ptest() {
26 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
27}
28
29RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
30
31FILES_${PN} += "${prefix}/src/backfire"