summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-03 12:14:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-04 14:13:33 +0100
commit2d97d6978073a4626074e82b8a6c5b003f003136 (patch)
tree117c4ace127183e51312d33d0d819259c51e7ed6 /meta/recipes-rt/rt-tests/rt-tests_2.0.bb
parent9e29916a9f06db3bbb42847ad04ead2a2dc06e6f (diff)
downloadpoky-2d97d6978073a4626074e82b8a6c5b003f003136.tar.gz
rt-tests, hwlatdetect: upgrade to 2.0
0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch has been merged upstream (From OE-Core rev: 2b6c5cc41c55e11509d5c1268dc1baab0a975d59) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_2.0.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_2.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
new file mode 100644
index 0000000000..21780d19ed
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
16 "
17# Do not install hwlatdetect
18EXTRA_OEMAKE += "PYLIB='' CROSS_COMPILE=${TARGET_PREFIX}"
19
20CFLAGS_prepend = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
21
22do_install() {
23 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
24 INCLUDEDIR=${includedir}
25}
26
27do_install_ptest() {
28 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
29}
30
31RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang"
32
33FILES_${PN} += "${prefix}/src/backfire"