summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_1.8.bb
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@intel.com>2020-10-19 14:42:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 13:22:48 +0000
commitf78ab0b39f7b49bff7b6d8b46b52fdcd0daf518f (patch)
tree7e9efa8cdc05c004f9ac0ea0ea3360cb4f238796 /meta/recipes-rt/rt-tests/rt-tests_1.8.bb
parentf3763062c3882d21f834511349c270ae9522ed52 (diff)
downloadpoky-f78ab0b39f7b49bff7b6d8b46b52fdcd0daf518f.tar.gz
rt-tests: Update recipes to use 1.8
John Kacur(the maintainer of rt-tests), recommends "that they use unstable/devel/latest as the maintained stable branch". I received this information on IRC, I couldn't find it documented anywhere else. This means that both rt-tests and hwlatdetect can be updated to be 1.8, the latest release on unstable/devel/latest. 0001-gzip-with-n-for-build-reproducibilty.patch was removed because upstream now uses "gzip -n" by default. (From OE-Core rev: 92b2386f0be0eac8ca761e2008288671c6f1dbb0) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_1.8.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.8.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.8.bb b/meta/recipes-rt/rt-tests/rt-tests_1.8.bb
new file mode 100644
index 0000000000..2834cabcd4
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_1.8.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc numactl"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9inherit ptest
10
11SRC_URI += " \
12 file://run-ptest \
13 file://rt_bmark.py \
14 file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \
15 "
16
17# rt-tests needs PI mutex support in libc
18COMPATIBLE_HOST_libc-musl = 'null'
19
20# Do not install hwlatdetect
21EXTRA_OEMAKE += "PYLIB=''"
22
23do_install() {
24 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
25 INCLUDEDIR=${includedir}
26}
27
28do_install_ptest() {
29 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
30}
31
32RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
33
34FILES_${PN} += "${prefix}/src/backfire"
35RDEPENDS_${PN} += "bash"