summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-01 15:30:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:34 +0000
commited1e36353a7873d8958e2b5c25c543417199885f (patch)
tree06fb56283421ffe8bab2d43a264c7ad66cf95efe /meta/recipes-rt/rt-tests/rt-tests_1.1.bb
parent6c6b6753c0d3494fa79ae493d5d798495a9b03ba (diff)
downloadpoky-ed1e36353a7873d8958e2b5c25c543417199885f.tar.gz
rt-tests: fix the recipe version to match upstream
Upstream had a 2.0 tag for a while, then removed it and added a 1.1 tag :-/ Let's make it match to avoid confusion. There's only one new commit added, which adds a missing manpage. Also, update the outdated version comment in rt-tests.inc (From OE-Core rev: 799a7b74f1219040fe2d43dcdcd145600a9fecbd) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_1.1.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
new file mode 100644
index 0000000000..4336c50d63
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
16 "
17# Do not install hwlatdetect
18EXTRA_OEMAKE += "PYLIB=''"
19
20do_install() {
21 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
22 INCLUDEDIR=${includedir}
23}
24
25do_install_ptest() {
26 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
27}
28
29RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
30
31FILES_${PN} += "${prefix}/src/backfire"