summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_0.94.bb
diff options
context:
space:
mode:
authorJosh Cartwright <joshc@ni.com>2015-09-22 07:24:38 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:39:32 +0000
commitc0fe43cdbef0e6edc1fea777b389b95275bbcc02 (patch)
tree3c9c371e13c777e9c1b6b12b913cd4199ac88205 /meta/recipes-rt/rt-tests/rt-tests_0.94.bb
parentcf972f9abf78111c2a7414356dac4d2a657b751f (diff)
downloadpoky-c0fe43cdbef0e6edc1fea777b389b95275bbcc02.tar.gz
rt-tests: bump to v0.94
All of the rt-tests patches that OE has been carrying have been upstreamed or superceded by changes in the v0.94 release. Adjust SRC_URI to point to canonical upstream git repo, instead of a development tree. There was a notable change upstream that required slight reworking of the recipe. rt-tests now joins other kbuild-inspired projects by making use of a CROSS_COMPILE flag to indicate the compiler prefix. Previously TOOLCHAIN_OPTIONS were conveyed via $CC directly, however, this does not work with CROSS_COMPILE. Workaround this by both specifying CROSS_COMPILE, and feeding the rt-tests build system the proper $(HOST_CC_ARCH)$(TOOLCHAIN_OPTIONS) via $CFLAGS. (From OE-Core rev: 37bd229626a259d2509a9cdd2d6a2d934121e9ca) Signed-off-by: Josh Cartwright <joshc@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.94.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.94.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.94.bb b/meta/recipes-rt/rt-tests/rt-tests_0.94.bb
new file mode 100644
index 0000000000..7d703925a8
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.94.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += "file://run-ptest \
14 file://rt_bmark.py \
15 "
16# Do not install hwlatdetect
17EXTRA_OEMAKE += "PYLIB='' CROSS_COMPILE=${TARGET_PREFIX}"
18
19CFLAGS_prepend = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
20
21do_install() {
22 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
23 INCLUDEDIR=${includedir}
24}
25
26do_install_ptest() {
27 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
28}
29
30RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang"
31
32FILES_${PN} += "${prefix}/src/backfire"