summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_0.84.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-09-11 21:17:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 15:13:52 +0100
commit244dd760116ed40f498aaaa38e18771f506c0054 (patch)
tree9740cf8c626373db47a653f5fd5decdaabe1964d /meta/recipes-rt/rt-tests/rt-tests_0.84.bb
parentc2383a34ea448832233c296dce74ba89cb71519f (diff)
downloadpoky-244dd760116ed40f498aaaa38e18771f506c0054.tar.gz
rt-tests: Update to 0.84, use the kernel.org git repository
The maintainer of rt-tests has recreated the git repository on kernel.org and has stated that kernel.org is now the official source for rt-tests. Update to 0.84. Remove the user cflags and ldflags patch as it is included in the 0.84 release. (From OE-Core rev: cdf84de3584e17b7fea2401cdb4eaae9752e98a2) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.84.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.84.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.84.bb b/meta/recipes-rt/rt-tests/rt-tests_0.84.bb
new file mode 100644
index 0000000000..c54936e13b
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.84.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=ce162fe491d19d2ec67dff6dbc938d50 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9# Version v0.84
10SRCREV = "857cdd5320ce1f293f5dbcbec79cc8fe22b0bebf"
11
12PR = "r0"
13
14SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git"
15
16S = "${WORKDIR}/git"
17
18# need to append rt-tests' default CFLAGS to ours
19CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnulli"
20
21# calling 'uname -m' is broken on crossbuilds
22EXTRA_OEMAKE = "NUMA=0"
23
24do_install() {
25 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
26 INCLUDEDIR=${includedir}
27}
28
29FILES_${PN} += "${prefix}/src/backfire"