summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-03 12:14:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-04 14:13:33 +0100
commit2d97d6978073a4626074e82b8a6c5b003f003136 (patch)
tree117c4ace127183e51312d33d0d819259c51e7ed6 /meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb
parent9e29916a9f06db3bbb42847ad04ead2a2dc06e6f (diff)
downloadpoky-2d97d6978073a4626074e82b8a6c5b003f003136.tar.gz
rt-tests, hwlatdetect: upgrade to 2.0
0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch has been merged upstream (From OE-Core rev: 2b6c5cc41c55e11509d5c1268dc1baab0a975d59) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb b/meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb
new file mode 100644
index 0000000000..012b2dd0a7
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_2.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
4SECTION = "tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9inherit python3-dir
10
11EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
12
13do_compile() {
14 oe_runmake hwlatdetect
15}
16
17do_install() {
18 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
19 MANDIR=${mandir} INCLUDEDIR=${includedir}
20
21 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py
22}
23
24FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
25RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
26RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"