summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-01 15:30:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:34 +0000
commited1e36353a7873d8958e2b5c25c543417199885f (patch)
tree06fb56283421ffe8bab2d43a264c7ad66cf95efe /meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
parent6c6b6753c0d3494fa79ae493d5d798495a9b03ba (diff)
downloadpoky-ed1e36353a7873d8958e2b5c25c543417199885f.tar.gz
rt-tests: fix the recipe version to match upstream
Upstream had a 2.0 tag for a while, then removed it and added a 1.1 tag :-/ Let's make it match to avoid confusion. There's only one new commit added, which adds a missing manpage. Also, update the outdated version comment in rt-tests.inc (From OE-Core rev: 799a7b74f1219040fe2d43dcdcd145600a9fecbd) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
new file mode 100644
index 0000000000..012b2dd0a7
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
4SECTION = "tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9inherit python3-dir
10
11EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
12
13do_compile() {
14 oe_runmake hwlatdetect
15}
16
17do_install() {
18 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
19 MANDIR=${mandir} INCLUDEDIR=${includedir}
20
21 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py
22}
23
24FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
25RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
26RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"