summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-06-17 11:01:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 10:23:53 +0100
commit02eb8620afa379d8b62f4cb761890068bb3232bc (patch)
tree42418daa8767f2993c182c76703400ed131a9daa /meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
parenta37e09e5f99c98a4b5953a0475955217ad817936 (diff)
downloadpoky-02eb8620afa379d8b62f4cb761890068bb3232bc.tar.gz
hwlatdetect: fix PV
As an extra safety measure set PV in the same place as SRCREV. (From OE-Core rev: cdbd772492812d2bd16ce9f3d5641910f9df240f) Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
new file mode 100644
index 0000000000..8319eb987a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
4SECTION = "tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9
10EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
11
12do_compile() {
13 oe_runmake hwlatdetect
14}
15
16do_install() {
17 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
18 MANDIR=${mandir} INCLUDEDIR=${includedir}
19}
20
21FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
22RDEPENDS_${PN} = "python python-subprocess python-textutils"
23RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"