summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-11-16 11:56:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-21 16:55:57 +0000
commit3881a549a4b89c24ed65dcb86cee050870902d28 (patch)
tree8f64841c95d0bc236b194c1e355cce3875847e09 /meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
parentfbb1228a7f81b51385fa565612ac9ce51ed80bd5 (diff)
downloadpoky-3881a549a4b89c24ed65dcb86cee050870902d28.tar.gz
rt-tests/hwlatdetect: Update to 0.85
(From OE-Core rev: 42fc047daa524ce4f1b9b1b2937d75375d796e6f) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
new file mode 100644
index 0000000000..a850a2d42a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
@@ -0,0 +1,24 @@
1pickDESCRIPTION = "Python hardware latency detector"
2HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
3SECTION = "tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6RDEPENDS = "python python-subprocess python-textutils"
7RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
8
9require rt-tests.inc
10
11PR = "${INC_PR}.0"
12
13EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
14
15do_compile() {
16 oe_runmake hwlatdetect
17}
18
19do_install() {
20 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
21 MANDIR=${mandir} INCLUDEDIR=${includedir}
22}
23
24FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"