summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-09-11 21:17:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 15:13:52 +0100
commitb3155c8393e208826c2da4a6d4a8e09fb996fcb9 (patch)
treeed5b5e21aa1cd653cd37412d6166a3d3fdff093e /meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb
parent244dd760116ed40f498aaaa38e18771f506c0054 (diff)
downloadpoky-b3155c8393e208826c2da4a6d4a8e09fb996fcb9.tar.gz
rt-tests: Add hwlatdetect package
Split out rt-tests into rt-tests and hwlatdetect packages as the latter requires python and we want to be able to install the core rt-tests on minimal systems without python. This also addresses QA warnings about the hwlatdetect files not being packaged. Add an RRECOMMENDS on the hwlat kernel module package for the new hwlatdetect package as the python test requires the kernel module to function properly (but we probably don't want to kill a build if the exact kernel module package is not available). (From OE-Core rev: 0ea5e5a805e038ecfeb6b87ca05c021c5f72c5e9) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb
new file mode 100644
index 0000000000..a850a2d42a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.84.bb
@@ -0,0 +1,24 @@
1pickDESCRIPTION = "Python hardware latency detector"
2HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
3SECTION = "tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6RDEPENDS = "python python-subprocess python-textutils"
7RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
8
9require rt-tests.inc
10
11PR = "${INC_PR}.0"
12
13EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
14
15do_compile() {
16 oe_runmake hwlatdetect
17}
18
19do_install() {
20 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
21 MANDIR=${mandir} INCLUDEDIR=${includedir}
22}
23
24FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"