summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-08 17:00:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 12:27:25 +0000
commit6be627fd5f2d1c0ef29d052164f23bc94f914b31 (patch)
tree7215368734f32fff9f0f79fe90e332e2e394a000 /meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
parent76c17122024e49fdc84e237b9d5dde6525778d6b (diff)
downloadpoky-6be627fd5f2d1c0ef29d052164f23bc94f914b31.tar.gz
qt4: build qmake for the target
qmake was not being built at all (since we had the host version from qt4-native) and the default is to build for the host machine within configure. With a minor hack we can build qmake for the target as well, which is useful if you want to build Qt 4 software on an actual device. This is now installed as part of the tools package (together with uic, moc etc.) Additionally, add an environment setup script (installed in /usr/share/qt4/environment-setup or /usr/share/qtopia/environment-setup for the embedded version) as part of the mkspecs package since the mkspecs will not work without the paths set up by this script. The code to create this script was adapted from the qmake2 recipe in meta-oe. Also move do_compile() from qt-${PV}.inc up to qt4.inc as both versions have the exact same content. (From OE-Core rev: 4306606489a2d922595d4c86a21c496bbd8a607e) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb')
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb b/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
index 6dedf0048a..e7f848e889 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
+++ b/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
@@ -1,7 +1,7 @@
1require qt4-x11-free.inc 1require qt4-x11-free.inc
2require qt-${PV}.inc 2require qt-${PV}.inc
3 3
4PR = "${INC_PR}.6" 4PR = "${INC_PR}.7"
5 5
6QT_CONFIG_FLAGS_append_armv6 = " -no-neon " 6QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
7 7