summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/qt-apps/qmmp_0.4.1.bb')
-rw-r--r--meta/recipes-qt/qt-apps/qmmp_0.4.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb b/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
new file mode 100644
index 0000000000..5f971e8b47
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/qmmp_0.4.1.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Qmmp (Qt-based Multimedia Player) is an audio-player, written with help of Qt library"
2HOMEPAGE = "http://qmmp.ylsoftware.com"
3LICENSE = "GPLv2"
4SECTION = "multimedia"
5
6DEPENDS = "qt4-x11-free"
7RDEPENDS = "qt4-x11-free libmad libvorbis libogg taglib alsa-lib curl"
8
9SRC_URI = "http://qmmp.ylsoftware.com/files/qmmp-0.4.1.tar.bz2"
10
11PARALLEL_MAKE = ""
12
13inherit qmake2 pkgconfig
14
15do_configure_prepend() {
16 # fix qt4 lrelease name
17 sed -i -e 's/lrelease-qt4/lrelease4/' ${S}/qmmp.pro
18
19 # disable the unsupported plugin
20 for plugin in sndfile wavpack ; do
21 sed -i -e "s/$plugin//" ${S}/src/plugins/Input/Input.pro
22 done
23 sed -i -e 's/mms//' ${S}/src/plugins/Transports/Transports.pro
24 sed -i -e 's/srconverter//' ${S}/src/plugins/Effect/Effect.pro
25
26 sed -i -e 's/^CONFIG/#CONFIG/' ${S}/qmmp.pri
27 sed -i -e 's/CONFIG += WITH_ENCA/#CONFIG += WITH_ENCA/' ${S}/qmmp.pri
28}
29
30do_install() {
31 oe_runmake INSTALL_ROOT=${D} install
32}