summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qmake/qmake2-cross_2.10a.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-qt/qmake/qmake2-cross_2.10a.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/qmake/qmake2-cross_2.10a.bb')
-rw-r--r--meta/recipes-qt/qmake/qmake2-cross_2.10a.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-qt/qmake/qmake2-cross_2.10a.bb b/meta/recipes-qt/qmake/qmake2-cross_2.10a.bb
new file mode 100644
index 0000000000..60f738b9ce
--- /dev/null
+++ b/meta/recipes-qt/qmake/qmake2-cross_2.10a.bb
@@ -0,0 +1,74 @@
1DESCRIPTION = "TrollTech Makefile Generator"
2PRIORITY = "optional"
3HOMEPAGE = "http://www.trolltech.com"
4SECTION = "devel"
5LICENSE = "GPL"
6PR = "r2"
7
8QTVER = "qt-embedded-linux-opensource-src-4.5.3"
9
10SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
11 file://0001-fix-mkspecs.patch;patch=1 \
12 file://use-lflags-last.patch;patch=1 \
13 file://linux-oe-qmake.conf"
14S = "${WORKDIR}/${QTVER}"
15
16# we need the real target system here
17CROSS_SYS := "${TARGET_SYS}"
18CROSS_BINDIR := "${STAGING_BINDIR_CROSS}"
19inherit autotools cross
20
21export QTDIR = "${S}"
22EXTRA_OEMAKE = "-e"
23EXTRA_OECONF = "-opensource"
24
25do_configure() {
26 # Install the OE build templates
27 for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++
28 do
29 install -d ${S}/mkspecs/$template
30 install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
31 ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h
32 done
33
34 QMAKESPEC=
35 PLATFORM=${HOST_OS}-oe-g++
36 export PLATFORM
37 # yes, TARGET_SYS is correct, because this is a 'cross'-qmake-native :) :M:
38 export OE_QMAKE_CC="${CC}"
39 export OE_QMAKE_CFLAGS="${CFLAGS}"
40 export OE_QMAKE_CXX="${CXX}"
41 export OE_QMAKE_CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
42 export OE_QMAKE_LDFLAGS="${LDFLAGS}"
43 export OE_QMAKE_LINK="${CCLD}"
44 export OE_QMAKE_AR="${AR}"
45 export OE_QMAKE_OBJCOPY="${OBJCOPY}"
46 export OE_QMAKE_STRIP="${STRIP}"
47 export OE_QMAKE_UIC="${STAGING_BINDIR_NATIVE}/uic"
48 export OE_QMAKE_MOC="${STAGING_BINDIR_NATIVE}/moc"
49 export OE_QMAKE_RCC="non-existant"
50 export OE_QMAKE_QMAKE="${STAGING_BINDIR_NATIVE}/qmake"
51 export OE_QMAKE_RPATH="-Wl,-rpath-link,"
52 echo yes | ./configure -prefix ${STAGING_DIR}/${CROSS_SYS}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed"
53}
54
55do_compile() {
56 :
57}
58
59do_install() {
60 install -d ${D}${CROSS_BINDIR}/
61 install -m 0755 bin/qmake ${D}${CROSS_BINDIR}/qmake2
62 install -m 0755 bin/qmake ${D}${CROSS_BINDIR}/qmake-qt4
63 install -d ${D}${STAGING_DIR}/${CROSS_SYS}/qt4/
64 cp -PfR mkspecs ${D}${STAGING_DIR}/${CROSS_SYS}/qt4/
65 install -d ${D}${STAGING_DIR}/${HOST_SYS}/qt4/
66 cp -PfR mkspecs ${D}${STAGING_DIR}/${HOST_SYS}/qt4/
67}
68
69sysroot_stage_all_append() {
70 sysroot_stage_dir ${D}/${STAGING_DIR_NATIVE}/qt4 ${SYSROOT_DESTDIR}/${STAGING_DIR_NATIVE}/qt4
71 sysroot_stage_dir ${D}/${STAGING_DIR_TARGET}/qt4 ${SYSROOT_DESTDIR}/${STAGING_DIR_TARGET}/qt4
72}
73
74