summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-30 13:58:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:52:58 +0100
commit07db74000443c473db401df598c4654fa6660436 (patch)
tree720885249bc800245bbee06834dd9cac35ba4ae0 /meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
parent8eba44660e495702fc68244fba64b6f08c1c9418 (diff)
downloadpoky-07db74000443c473db401df598c4654fa6660436.tar.gz
packagegroup-qt4e: tidy up and rename
* Eliminate the -base package, there's only one package and it might as well be the main one. * Rename to packagegroup-core-qt4e to match other package group recipes * Fix and tidy up qt4e-demo-image at the same time (From OE-Core rev: 9dddc9dfdc84401fee3b48eb3aba0cabdcf4d05a) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb')
-rw-r--r--meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
new file mode 100644
index 0000000000..2ea9c2e551
--- /dev/null
+++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "QT4 Embedded base Image Feed"
2PR = "r1"
3LICENSE = "MIT"
4
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8inherit packagegroup
9
10TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
11
12RDEPENDS_${PN} = " \
13 qt4-embedded \
14 libqt-embedded3support4 \
15 libqt-embeddedclucene4 \
16 libqt-embeddedcore4 \
17 libqt-embeddeddbus4 \
18 libqt-embeddedgui4 \
19 libqt-embeddedhelp4 \
20 libqt-embeddedmultimedia4 \
21 libqt-embeddednetwork4 \
22 libqt-embeddedscript4 \
23 libqt-embeddedscripttools4 \
24 libqt-embeddedsql4 \
25 libqt-embeddedsvg4 \
26 libqt-embeddedtest4 \
27 libqt-embeddedwebkit4 \
28 libqt-embeddedxml4 \
29 qt4-embedded-fonts-ttf-dejavu \
30 qt4-embedded-fonts-ttf-vera \
31 qt4-embedded-plugin-iconengine-svgicon \
32 qt4-embedded-plugin-imageformat-gif \
33 qt4-embedded-plugin-imageformat-ico \
34 qt4-embedded-plugin-imageformat-jpeg \
35 qt4-embedded-plugin-imageformat-mng \
36 qt4-embedded-plugin-imageformat-svg \
37 qt4-embedded-plugin-imageformat-tiff \
38 qt4-embedded-plugin-mousedriver-tslib \
39 qt4-embedded-plugin-phonon-backend-gstreamer \
40 qt4-embedded-plugin-script-dbus \
41 qt4-embedded-plugin-sqldriver-sqlite \
42 ${TOUCH} \
43 qt4-embedded-demos \
44 qt4-embedded-examples \
45 qt-demo-init \
46 qt4-embedded-assistant \
47"
48
49RRECOMMENDS_${PN} = " \
50 libqt-embeddedxmlpatterns4 \
51"
52