diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-08-05 17:42:58 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-08-13 23:05:58 +0100 |
commit | 70711312008eda97ece45af73d68ba86f714a13f (patch) | |
tree | 4a276ce584cd1c62abbef1e4389d8872dd6de500 /meta/recipes-multimedia/x264/x264_git.bb | |
parent | 2d493e9b24d7fac9547429294a78d4f10c2cc62f (diff) | |
download | poky-70711312008eda97ece45af73d68ba86f714a13f.tar.gz |
x264: add from meta-oe, update and tweak
This is required by the default configuration of libav being brought over
from meta-oe. Changes from the meta-oe recipe:
* Update to the latest revision from the stable branch (upstream does
not seem to provide stable releases.)
* Add LICENSE_FLAGS = "commercial"
* Enable PIC to fix text relocation warnings and disable warning for
i586 (since PIC can't be used there)
* Make SUMMARY value slightly shorter
* Indent SRC_URI consistently with other recipes in OE-Core
(From OE-Core rev: a3ca077285003fbc04d134e875a58a745271e47f)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/x264/x264_git.bb')
-rw-r--r-- | meta/recipes-multimedia/x264/x264_git.bb | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb new file mode 100644 index 0000000000..295818ae98 --- /dev/null +++ b/meta/recipes-multimedia/x264/x264_git.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | SUMMARY = "A free software library and application for encoding video streams into the H.264/MPEG-4 AVC format" | ||
2 | HOMEPAGE = "http://www.videolan.org/developers/x264.html" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LICENSE_FLAGS = "commercial" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
7 | |||
8 | DEPENDS = "yasm-native" | ||
9 | |||
10 | SRC_URI = "git://git.videolan.org/x264.git \ | ||
11 | file://don-t-default-to-cortex-a9-with-neon.patch \ | ||
12 | " | ||
13 | |||
14 | SRCREV = "585324fee380109acd9986388f857f413a60b896" | ||
15 | |||
16 | PV = "r2265+git${SRCPV}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | inherit lib_package pkgconfig | ||
21 | |||
22 | X264_DISABLE_ASM = "" | ||
23 | X264_DISABLE_ASM_armv4 = "--disable-asm" | ||
24 | X264_DISABLE_ASM_armv5 = "--disable-asm" | ||
25 | |||
26 | EXTRA_OECONF = '--prefix=${prefix} \ | ||
27 | --host=${HOST_SYS} \ | ||
28 | --cross-prefix=${TARGET_PREFIX} \ | ||
29 | --sysroot=${STAGING_DIR_TARGET} \ | ||
30 | --enable-shared \ | ||
31 | --enable-static \ | ||
32 | --disable-lavf \ | ||
33 | --disable-swscale \ | ||
34 | --enable-pic \ | ||
35 | ${X264_DISABLE_ASM} \ | ||
36 | ' | ||
37 | |||
38 | do_configure() { | ||
39 | ./configure ${EXTRA_OECONF} | ||
40 | } | ||
41 | |||
42 | # Get rid of -e | ||
43 | EXTRA_OEMAKE = "" | ||
44 | AS = "${TARGET_PREFIX}gcc" | ||
45 | |||
46 | do_install() { | ||
47 | oe_runmake install DESTDIR=${D} | ||
48 | } | ||
49 | |||
50 | # PIC can't be enabled for 32-bit x86 | ||
51 | INSANE_SKIP_${PN}_append_i586 = " textrel" | ||
52 | |||