summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.1.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-11-18 15:28:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-21 23:08:19 +0000
commitf931a332d1db0730b4edc05ce19105b9d7909ec3 (patch)
treeb887c970077204594a71a3e01e6cb8fab62f543a /meta/recipes-multimedia/libtiff/tiff_4.1.0.bb
parentf681fd3b2fd69b6ecf71c317bc4a8e8786c0a38f (diff)
downloadpoky-f931a332d1db0730b4edc05ce19105b9d7909ec3.tar.gz
tiff: update to 4.1.0
Drop backported patches. (From OE-Core rev: e5ecf2604e5b8c957eb3bae21fb3c9b2b1b7e12f) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.1.0.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.1.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.1.0.bb b/meta/recipes-multimedia/libtiff/tiff_4.1.0.bb
new file mode 100644
index 0000000000..1f92c18513
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.1.0.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 "
9SRC_URI[md5sum] = "2165e7aba557463acc0664e71a3ed424"
10SRC_URI[sha256sum] = "5d29f32517dadb6dbcd1255ea5bbc93a2b54b94fbf83653b4d65c7d6775b8634"
11
12# exclude betas
13UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
14
15inherit autotools multilib_header
16
17CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
18
19PACKAGECONFIG ?= "cxx jpeg zlib lzma \
20 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
21
22PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
23PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
24PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
25PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
26
27# Convert single-strip uncompressed images to multiple strips of specified
28# size (default: 8192) to reduce memory usage
29PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
30
31# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
32PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
33
34# Control picking up YCbCr subsample info. Disable to support files lacking
35# the tag
36PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
37
38# Support a mechanism allowing reading large strips (usually one strip files)
39# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
40PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
41
42PACKAGES =+ "tiffxx tiff-utils"
43FILES_tiffxx = "${libdir}/libtiffxx.so.*"
44FILES_tiff-utils = "${bindir}/*"
45
46do_install_append() {
47 oe_multilib_header tiffconf.h
48}
49
50BBCLASSEXTEND = "native"