summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.9.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-11-22 16:41:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-23 23:35:18 +0000
commit691e3069941db750261a85ed8c7f8a506bbe9b3e (patch)
tree88df05bf89ed2e9ee1d565bf4cb64cd25321cd87 /meta/recipes-multimedia/libtiff/tiff_4.0.9.bb
parent71c0092d16c97fcd5869dc85714ca56fab173ed2 (diff)
downloadpoky-691e3069941db750261a85ed8c7f8a506bbe9b3e.tar.gz
tiff: update to 4.0.10
(From OE-Core rev: 92a2e6dc73085ccb5482986c6b61d40992fb4f50) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.9.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.9.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.9.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.9.bb
deleted file mode 100644
index 93beddb4da..0000000000
--- a/meta/recipes-multimedia/libtiff/tiff_4.0.9.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 file://CVE-2017-9935.patch \
10 file://CVE-2017-18013.patch \
11 file://CVE-2018-5784.patch \
12 file://CVE-2018-10963.patch \
13 file://CVE-2018-8905.patch \
14 file://CVE-2018-7456.patch \
15 file://CVE-2017-17095.patch \
16 "
17
18SRC_URI[md5sum] = "54bad211279cc93eb4fca31ba9bfdc79"
19SRC_URI[sha256sum] = "6e7bdeec2c310734e734d19aae3a71ebe37a4d842e0e23dbb1b8921c0026cfcd"
20
21# exclude betas
22UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
23
24inherit autotools multilib_header
25
26CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
27
28PACKAGECONFIG ?= "cxx jpeg zlib lzma \
29 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
30
31PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
32PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
33PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
34PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
35
36# Convert single-strip uncompressed images to multiple strips of specified
37# size (default: 8192) to reduce memory usage
38PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
39
40# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
41PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
42
43# Control picking up YCbCr subsample info. Disable to support files lacking
44# the tag
45PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
46
47# Support a mechanism allowing reading large strips (usually one strip files)
48# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
49PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
50
51PACKAGES =+ "tiffxx tiff-utils"
52FILES_tiffxx = "${libdir}/libtiffxx.so.*"
53FILES_tiff-utils = "${bindir}/*"
54
55do_install_append() {
56 oe_multilib_header tiffconf.h
57}
58
59BBCLASSEXTEND = "native"