summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.8.bb
diff options
context:
space:
mode:
authorFan Xin <fan.xin@jp.fujitsu.com>2017-06-07 17:11:56 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-09 17:12:14 +0100
commit68e25dfade6bd00b1c7186ffc8aa944e9b1bf28a (patch)
tree61f9bc2266489883cb453442b70e84d2cd4dd7d2 /meta/recipes-multimedia/libtiff/tiff_4.0.8.bb
parent1b9e549949f444fe4cea7d2bca0a2d3655ec5391 (diff)
downloadpoky-68e25dfade6bd00b1c7186ffc8aa944e9b1bf28a.tar.gz
libtiff: Upgrade to 4.0.8
1. Upgrade libtiff from 4.0.7 to 4.0.8 2. Delete the following patch file due to CVE-2017-5225 has been fixed in 4.0.8 libtiff-CVE-2017-5225.patch (From OE-Core rev: 825927e85933322e6f195f0d937359017a9a9b97) Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.8.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.8.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.8.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.8.bb
new file mode 100644
index 0000000000..4a7aeccd23
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.8.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 "
10
11SRC_URI[md5sum] = "2a7d1c1318416ddf36d5f6fa4600069b"
12SRC_URI[sha256sum] = "59d7a5a8ccd92059913f246877db95a2918e6c04fb9d43fd74e5c3390dac2910"
13
14# exclude betas
15UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
16
17inherit autotools
18
19CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
20
21PACKAGECONFIG ?= "cxx jpeg zlib lzma \
22 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
23
24PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
25PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
26PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
27PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
28
29# Convert single-strip uncompressed images to multiple strips of specified
30# size (default: 8192) to reduce memory usage
31PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
32
33# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
34PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
35
36# Control picking up YCbCr subsample info. Disable to support files lacking
37# the tag
38PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
39
40# Support a mechanism allowing reading large strips (usually one strip files)
41# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
42PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
43
44PACKAGES =+ "tiffxx tiff-utils"
45FILES_tiffxx = "${libdir}/libtiffxx.so.*"
46FILES_tiff-utils = "${bindir}/*"
47
48BBCLASSEXTEND = "native"