summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-12-10 09:38:43 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-11 17:21:45 +0000
commitbaf73313b3f63537853278992fa7c00775a6eff4 (patch)
treed5983f67c33f88b81df914f0cfbf5883d4de4877 /meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
parent985beaaa1309a97d42aa0f886096db041060a95e (diff)
downloadpoky-baf73313b3f63537853278992fa7c00775a6eff4.tar.gz
libtiff: Update to 4.0.7
Major changes: The libtiff tools bmp2tiff, gif2tiff, ras2tiff, sgi2tiff, sgisv, and ycbcr are completely removed from the distribution, used for demos. CVEs fixed: CVE-2016-9297 CVE-2016-9448 CVE-2016-9273 CVE-2014-8127 CVE-2016-3658 CVE-2016-5875 CVE-2016-5652 CVE-2016-3632 plus more that are not identified in the changelog. removed patches integrated into update. more info: http://libtiff.maptools.org/v4.0.7.html (From OE-Core rev: 9945cbccc4c737c84ad441773061acbf90c7baed) (From OE-Core rev: 009b330591b27bd14d4c8ceb767c78fd7eb924fd) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.7.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.7.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
new file mode 100644
index 0000000000..729678208f
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 "
10
11SRC_URI[md5sum] = "77ae928d2c6b7fb46a21c3a29325157b"
12SRC_URI[sha256sum] = "9f43a2cfb9589e5cecaa66e16bf87f814c945f22df7ba600d63aac4632c4f019"
13
14# exclude betas
15UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
16
17inherit autotools
18
19CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
20
21PACKAGECONFIG ?= "cxx jpeg zlib lzma \
22 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
23
24PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
25PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
26PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
27PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
28
29# Convert single-strip uncompressed images to multiple strips of specified
30# size (default: 8192) to reduce memory usage
31PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
32
33# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
34PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
35
36# Control picking up YCbCr subsample info. Disable to support files lacking
37# the tag
38PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
39
40# Support a mechanism allowing reading large strips (usually one strip files)
41# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
42PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
43
44PACKAGES =+ "tiffxx tiff-utils"
45FILES_tiffxx = "${libdir}/libtiffxx.so.*"
46FILES_tiff-utils = "${bindir}/*"
47
48BBCLASSEXTEND = "native"