summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.4.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2015-06-26 16:27:51 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-27 22:42:56 +0100
commite3b35f56a80d3adbe997950702dd5eba243d1bbc (patch)
treecf60d53a7c14319f5eebc2a23464d2cafaf2b862 /meta/recipes-multimedia/libtiff/tiff_4.0.4.bb
parentb3fc3748a0789463942e06cf5761af0c142eba72 (diff)
downloadpoky-e3b35f56a80d3adbe997950702dd5eba243d1bbc.tar.gz
tiff: Update to 4.0.4
Update tiff to latest version. None of the local CVE patches are needed based on reviewing the ChangeLog so remove them. (From OE-Core rev: 5c5d7c2ab0d32faca43ba360d5d42ecd2822c730) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.4.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.4.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.4.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.4.bb
new file mode 100644
index 0000000000..cf3a5f04c5
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.4.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4HOMEPAGE = "http://www.remotesensing.org/libtiff/"
5
6SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
7 file://libtool2.patch \
8 "
9
10SRC_URI[md5sum] = "9aee7107408a128c0c7b24286c0db900"
11SRC_URI[sha256sum] = "8cb1d90c96f61cdfc0bcf036acc251c9dbe6320334da941c7a83cfe1576ef890"
12
13inherit autotools
14
15CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
16
17PACKAGECONFIG ?= "cxx jpeg zlib lzma \
18 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
19
20PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
21PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
22PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
23PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
24
25# Convert single-strip uncompressed images to multiple strips of specified
26# size (default: 8192) to reduce memory usage
27PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
28
29# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
30PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
31
32# Control picking up YCbCr subsample info. Disable to support files lacking
33# the tag
34PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
35
36# Support a mechanism allowing reading large strips (usually one strip files)
37# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
38PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
39
40PACKAGES =+ "tiffxx tiff-utils"
41FILES_tiffxx = "${libdir}/libtiffxx.so.*"
42FILES_tiff-utils = "${bindir}/*"
43
44BBCLASSEXTEND = "native"