summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.10.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-11-22 16:41:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-23 23:35:18 +0000
commit691e3069941db750261a85ed8c7f8a506bbe9b3e (patch)
tree88df05bf89ed2e9ee1d565bf4cb64cd25321cd87 /meta/recipes-multimedia/libtiff/tiff_4.0.10.bb
parent71c0092d16c97fcd5869dc85714ca56fab173ed2 (diff)
downloadpoky-691e3069941db750261a85ed8c7f8a506bbe9b3e.tar.gz
tiff: update to 4.0.10
(From OE-Core rev: 92a2e6dc73085ccb5482986c6b61d40992fb4f50) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.10.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.10.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.10.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.10.bb
new file mode 100644
index 0000000000..152fa819a5
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.10.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 "
10
11SRC_URI[md5sum] = "114192d7ebe537912a2b97408832e7fd"
12SRC_URI[sha256sum] = "2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4"
13
14# exclude betas
15UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
16
17inherit autotools multilib_header
18
19CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
20
21PACKAGECONFIG ?= "cxx jpeg zlib lzma \
22 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
23
24PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
25PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
26PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
27PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
28
29# Convert single-strip uncompressed images to multiple strips of specified
30# size (default: 8192) to reduce memory usage
31PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
32
33# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
34PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
35
36# Control picking up YCbCr subsample info. Disable to support files lacking
37# the tag
38PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
39
40# Support a mechanism allowing reading large strips (usually one strip files)
41# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
42PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
43
44PACKAGES =+ "tiffxx tiff-utils"
45FILES_tiffxx = "${libdir}/libtiffxx.so.*"
46FILES_tiff-utils = "${bindir}/*"
47
48do_install_append() {
49 oe_multilib_header tiffconf.h
50}
51
52BBCLASSEXTEND = "native"