summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-12-12 15:29:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-13 23:31:40 +0000
commitc06035d693eacf47058ac36d8b599d30a4b65bdf (patch)
tree5eb1caf03ceb03a82b3590ab1962c2236b81cf05 /meta/recipes-multimedia/libpng/libpng_1.6.39.bb
parent27499bd131ba3acea679803dff93fb0fe1c0b7bf (diff)
downloadpoky-c06035d693eacf47058ac36d8b599d30a4b65bdf.tar.gz
libpng: upgrade 1.6.38 -> 1.6.39
Changelog: ========== * Changed the error handler of oversized chunks (i.e. larger than PNG_USER_CHUNK_MALLOC_MAX) from png_chunk_error to png_benign_error. * Fixed a buffer overflow error in contrib/tools/pngfix. * Fixed a memory leak (CVE-2019-6129) in contrib/tools/pngcp. * Disabled the ARM Neon optimizations by default in the CMake file, following the default behavior of the configure script. * Allowed configure.ac to work with the trunk version of autoconf. * Removed the support for "install" targets from the legacy makefiles; removed the obsolete makefile.cegcc. * Cleaned up the code and updated the internal documentation. (From OE-Core rev: 19799cb50a00561b318cba1c8c20737f20e4a47f) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libpng/libpng_1.6.39.bb')
-rw-r--r--meta/recipes-multimedia/libpng/libpng_1.6.39.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
new file mode 100644
index 0000000000..d9dcf379e9
--- /dev/null
+++ b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
@@ -0,0 +1,34 @@
1SUMMARY = "PNG image format decoding library"
2DESCRIPTION = "An open source project to develop and maintain the reference \
3library for use in applications that read, create, and manipulate PNG \
4(Portable Network Graphics) raster image files. "
5HOMEPAGE = "http://www.libpng.org/"
6SECTION = "libs"
7LICENSE = "Libpng"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=5c900cc124ba35a274073b5de7639b13"
9DEPENDS = "zlib"
10
11LIBV = "16"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz"
14SRC_URI[sha256sum] = "1f4696ce70b4ee5f85f1e1623dc1229b210029fa4b7aee573df3e2ba7b036937"
15
16MIRRORS += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/older-releases/"
17
18UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html"
19
20BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
21
22inherit autotools binconfig-disabled pkgconfig
23
24# Work around missing symbols
25EXTRA_OECONF:append:class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
26
27PACKAGES =+ "${PN}-tools"
28
29FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp"
30
31BBCLASSEXTEND = "native nativesdk"
32
33# CVE-2019-17371 is actually a memory leak in gif2png 2.x
34CVE_CHECK_IGNORE += "CVE-2019-17371"