diff options
author | Jose Quaresma <quaresma.jose@gmail.com> | 2021-10-04 00:41:55 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-10-11 18:41:39 +0100 |
commit | 5847afb51dd4b7fbd207c795876fe1e6a76a3460 (patch) | |
tree | 6a9337a674da7098fbd45c0830dcea730c3b749e /meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.bb | |
parent | dae4a4e27a4ef431ffa0ffb0ae79e654a7ee1c51 (diff) | |
download | poky-5847afb51dd4b7fbd207c795876fe1e6a76a3460.tar.gz |
gstreamer1.0: 1.18.4 -> 1.18.5
(From OE-Core rev: d325f0d31bb1cbe889c7303ac2999c4dae391b34)
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.bb')
-rw-r--r-- | meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.bb | 75 |
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.bb new file mode 100644 index 0000000000..0d82dd338c --- /dev/null +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.bb | |||
@@ -0,0 +1,75 @@ | |||
1 | SUMMARY = "GStreamer 1.0 multimedia framework" | ||
2 | DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \ | ||
3 | It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime." | ||
4 | HOMEPAGE = "http://gstreamer.freedesktop.org/" | ||
5 | BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer" | ||
6 | SECTION = "multimedia" | ||
7 | LICENSE = "LGPLv2+" | ||
8 | |||
9 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native" | ||
10 | |||
11 | inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection ptest-gnome | ||
12 | |||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \ | ||
14 | file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d" | ||
15 | |||
16 | S = "${WORKDIR}/gstreamer-${PV}" | ||
17 | |||
18 | SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \ | ||
19 | file://run-ptest \ | ||
20 | file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \ | ||
21 | file://0002-Remove-unused-valgrind-detection.patch \ | ||
22 | file://0003-tests-seek-Don-t-use-too-strict-timeout-for-validati.patch \ | ||
23 | file://0004-tests-respect-the-idententaion-used-in-meson.patch \ | ||
24 | file://0005-tests-add-support-for-install-the-tests.patch \ | ||
25 | file://0006-tests-use-a-dictionaries-for-environment.patch \ | ||
26 | file://0007-tests-install-the-environment-for-installed_tests.patch \ | ||
27 | " | ||
28 | SRC_URI[sha256sum] = "55862232a63459bbf56abebde3085ca9aec211b478e891dacea4d6df8cafe80a" | ||
29 | |||
30 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \ | ||
31 | check \ | ||
32 | debug \ | ||
33 | tools" | ||
34 | |||
35 | PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false" | ||
36 | PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false" | ||
37 | PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled" | ||
38 | PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled" | ||
39 | PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false" | ||
40 | PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind" | ||
41 | PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils" | ||
42 | PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion" | ||
43 | PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled" | ||
44 | PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native" | ||
45 | |||
46 | # TODO: put this in a gettext.bbclass patch | ||
47 | def gettext_oemeson(d): | ||
48 | if d.getVar('USE_NLS') == 'no': | ||
49 | return '-Dnls=disabled' | ||
50 | # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set | ||
51 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): | ||
52 | return '-Dnls=disabled' | ||
53 | return '-Dnls=enabled' | ||
54 | |||
55 | EXTRA_OEMESON += " \ | ||
56 | -Ddoc=disabled \ | ||
57 | -Dexamples=disabled \ | ||
58 | -Ddbghelp=disabled \ | ||
59 | ${@gettext_oemeson(d)} \ | ||
60 | " | ||
61 | |||
62 | GIR_MESON_ENABLE_FLAG = "enabled" | ||
63 | GIR_MESON_DISABLE_FLAG = "disabled" | ||
64 | |||
65 | PACKAGES += "${PN}-bash-completion" | ||
66 | |||
67 | # Add the core element plugins to the main package | ||
68 | FILES:${PN} += "${libdir}/gstreamer-1.0/*.so" | ||
69 | FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include" | ||
70 | FILES:${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*" | ||
71 | FILES:${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb" | ||
72 | |||
73 | CVE_PRODUCT = "gstreamer" | ||
74 | |||
75 | PTEST_BUILD_HOST_FILES = "" | ||