summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-05-25 14:20:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-18 11:07:57 +0100
commit760127420cec852da7e8e72661c9ff70fa1c97c5 (patch)
treeb829a3b3965a225840029169ebef641bc5b60206 /meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
parentc7fbb0251bf560c3e9ac847696e8a735dc8ee787 (diff)
downloadpoky-760127420cec852da7e8e72661c9ff70fa1c97c5.tar.gz
gstreamer: enable ptest support
Make sure that the tests are packaged and can be executed when ptest is enabled. Also, remove build host specific references from Makefile. (From OE-Core rev: d283b0eb909c78b020794ba78e7ec64c3fbee86f) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb26
1 files changed, 24 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
index dec1783fdd..5ce9f24efe 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
@@ -8,7 +8,7 @@ LICENSE = "LGPLv2+"
8 8
9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native" 9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
10 10
11inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc 11inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc ptest
12 12
13# This way common/m4/introspection.m4 will come first 13# This way common/m4/introspection.m4 will come first
14# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file) 14# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file)
@@ -24,11 +24,14 @@ SRC_URI = " \
24 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ 24 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
25 file://gtk-doc-tweaks.patch \ 25 file://gtk-doc-tweaks.patch \
26 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \ 26 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
27 file://add-a-target-to-compile-tests.patch \
28 file://run-ptest \
27" 29"
28SRC_URI[md5sum] = "63c7cbfb86aa28c4522e374dc5555b96" 30SRC_URI[md5sum] = "63c7cbfb86aa28c4522e374dc5555b96"
29SRC_URI[sha256sum] = "fc361367f0d4b780a868a8833f9f30b9c9f4ac9faea4e6b251db8b4b0398466e" 31SRC_URI[sha256sum] = "fc361367f0d4b780a868a8833f9f30b9c9f4ac9faea4e6b251db8b4b0398466e"
30 32
31PACKAGECONFIG ??= "" 33PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
34 "
32 35
33PACKAGECONFIG[debug] = "--enable-debug,--disable-debug" 36PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
34PACKAGECONFIG[tests] = "--enable-tests,--disable-tests" 37PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
@@ -54,6 +57,7 @@ FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadi
54 57
55RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi" 58RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
56RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi" 59RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
60RDEPENDS_${PN}-ptest += "make"
57 61
58delete_pkg_m4_file() { 62delete_pkg_m4_file() {
59 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection 63 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
@@ -67,4 +71,22 @@ do_compile_prepend() {
67 export GIR_EXTRA_LIBS_PATH="${B}/gst/.libs:${B}/libs/gst/base/.libs" 71 export GIR_EXTRA_LIBS_PATH="${B}/gst/.libs:${B}/libs/gst/base/.libs"
68} 72}
69 73
74do_compile_ptest() {
75 oe_runmake build-checks
76}
77
78do_install_ptest() {
79 oe_runmake -C tests/check DESTDIR=${D}${PTEST_PATH} install-ptest
80 install -m 644 ${B}/tests/check/Makefile ${D}${PTEST_PATH}
81 install -m 755 ${S}/test-driver ${D}${PTEST_PATH}
82 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
83 -e 's|${DEBUG_PREFIX_MAP}||g' \
84 -e 's:${HOSTTOOLS_DIR}/::g' \
85 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
86 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
87 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
88 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
89 -i ${D}${PTEST_PATH}/Makefile
90}
91
70CVE_PRODUCT = "gstreamer" 92CVE_PRODUCT = "gstreamer"