summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2022-02-19 20:15:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-02 00:22:13 +0000
commitcc553bc2732d161a08362184cbc0d4181bf74773 (patch)
tree049760aa16402d0130e47d5917d2781ff8e2dbec /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb
parent012a08a95c475b6367e6f8a5d32e1b7de37ec098 (diff)
downloadpoky-cc553bc2732d161a08362184cbc0d4181bf74773.tar.gz
gstreamer1.0-python: 1.18.5 -> 1.18.6
(From OE-Core rev: 8cabb662e4298ca786a7e082c91938bc3858b611) Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb
new file mode 100644
index 0000000000..1a3ae5dde6
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.6.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \
3provided by python-gi) "
4HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
5SECTION = "multimedia"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
11SRC_URI[sha256sum] = "bdc0ea22fbd7335ad9decc151561aacc53c51206a9735b81eac700ce5b0bbd4a"
12
13DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
14RDEPENDS_${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
15
16PNREAL = "gst-python"
17
18S = "${WORKDIR}/${PNREAL}-${PV}"
19
20EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
21
22# gobject-introspection is mandatory and cannot be configured
23REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
24UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
25
26inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check