summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-10-04 00:42:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-29 11:17:25 +0100
commitfa13f88d19ec8fc740a2d74bd4ceeae45a61da2d (patch)
tree94f0c1f56f4fca366fec631fad559080b8d25b9a /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb
parent11ff9d080a7724a835d61f80033e928f40a61a75 (diff)
downloadpoky-fa13f88d19ec8fc740a2d74bd4ceeae45a61da2d.tar.gz
gstreamer1.0-python: 1.18.4 -> 1.18.5
(From OE-Core rev: 9b436d2f69d1594e3efa33153226a269f09f3130) Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> (cherry picked from commit 3c68529eb99c74de5a30520261f62a5544be9b39) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb
new file mode 100644
index 0000000000..74dd15b3eb
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.5.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \
3provided by python-gi) "
4HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
5SECTION = "multimedia"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
11SRC_URI[sha256sum] = "533685871305959d6db89507f3b3aa6c765c2f2b0dacdc32c5a6543e72e5bc52"
12
13DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
14RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
15
16PNREAL = "gst-python"
17
18S = "${WORKDIR}/${PNREAL}-${PV}"
19
20EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
21
22# gobject-introspection is mandatory and cannot be configured
23REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
24UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
25
26inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check