summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2020-10-25 14:23:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 17:23:20 +0000
commitefd0dcee46b50cbb451ec278fe7183c7275f5170 (patch)
treec1270ae021b88661bbab7a5e405bea773dc8a0be /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb
parentb50bd0dbd573ac9e180210c7d50a74033e846fd4 (diff)
downloadpoky-efd0dcee46b50cbb451ec278fe7183c7275f5170.tar.gz
gstreamer1.0-python: Update 1.16.2 -> Update 1.16.3
(From OE-Core rev: 5e93456e8e03d457173d7b07ba030b86d50b7335) Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb
new file mode 100644
index 0000000000..14b34a2808
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.3.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "326f4f4c23e2477bf3d5839c465a42ca"
10SRC_URI[sha256sum] = "36a00a256c25ccaaa9b965a6f09d6158dfb77558145ab6b25809938732c7161f"
11
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
19# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
22
23inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check
24
25do_install_append() {
26
27 # Note that this particular find line is taken from the Debian packaging for
28 # gst-python1.0.
29 find "${D}" \
30 -name '*.pyc' -o \
31 -name '*.pyo' -o \
32 -name '*.la' -o \
33 -name 'libgstpythonplugin*' \
34 -delete
35}