summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2019-10-22 16:59:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:39:05 +0000
commita871348edad1a81a1d4f5c8dc0766c61e0019d8e (patch)
treeeb5a3ac14c9bc7f9ebb32fc4d29bf62ce5356900 /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb
parent321b80ebb34b649737adfc23f83bb4786526b339 (diff)
downloadpoky-a871348edad1a81a1d4f5c8dc0766c61e0019d8e.tar.gz
gstreamer1.0-python: upgrade to version 1.16.1
(From OE-Core rev: 889f715817b4da91a62347cad85043ce5de30e46) Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb
new file mode 100644
index 0000000000..52ed150482
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.1.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "499645fbd1790c5845c02a3998dccc1b"
10SRC_URI[sha256sum] = "b469c8955126f41b8ce0bf689b7029f182cd305f422b3a8df35b780bd8347489"
11
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
19# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
22
23inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
24
25EXTRA_OECONF += "--with-libpython-dir=${libdir}"
26
27do_install_append() {
28
29 # Note that this particular find line is taken from the Debian packaging for
30 # gst-python1.0.
31 find "${D}" \
32 -name '*.pyc' -o \
33 -name '*.pyo' -o \
34 -name '*.la' -o \
35 -name 'libgstpythonplugin*' \
36 -delete
37}